Toshiba laptop power supply/battery problem, but where ?

  greybeard 22:25 21 Apr 2013

I'm running ubuntu 12.04 on a Toshiba A30 Satellite laptop, and the following power supply problem has arisen, so I'd be grateful to anyone who can provide some clues as to what action might cure it.

I have hard wired my ac adapter so that dc power to the laptop is OK, and not likely to be at fault. Moving the connector where it joins the back of the machine produces no sign of anything untoward either.

a) If I start the laptop with the battery fully charged, after a random time of the order of minutes not hours, the taskbar indicator shows the battery is rapidly losing charge, then the indicator switches to 'battery not present', with the 'battery' led going out. The laptop then runs for a short time before turning off.(The Toshiba will succesfully boot up without a battery present, and continue to operate for some time, but not for ever!)

b) If I boot up the laptop with the led indicating a partially charged battery, the above sequence occurs, just completes more quickly.

In either case, the laptop closes down, leaving just the 'mains power' led indicating that a power source is connected. If I now press the button to start the boot sequence, nothing will happen. If, however, I turn off the power at the wall socket, then immediately turn it back on, both the 'power source' and 'battery' leds come on, and pressing the start button will boot up the computer into the (b) scenario. If I leave the laptop with the power still switched on to the ac adapter, the battery will indicate fully charged in about 20 mins for one, or 40 mins for the other.

I have tried the above with two batteries, admittedly both used, but the symptoms remain the same, so I would need a lot of persuading that a new battery is the answer !


  electroscallic 04:37 23 Apr 2013

I had this same problem with a similar Toshiba laptop. It turned out that because I over-lengthened the faulty power supply cable, there was too much electrical resistance going through the cable (and I only extended it like 1m). As soon as I removed the lengthened part of the cable and re-shortened it, the computer could charge again while being powered on. For me the problem dawned on me from physics class. I thought maybe you had the same problem because you also hard-wired it to your laptop like I did (unless this problem does not happen with other operating systems).

  woodchip 10:31 23 Apr 2013

The Problem is not the Wire length its a Faulty Power supply. 240 volts will go through any length under normal conditions as long as the wire is not coiled up. if you have mess't with cables on power supply this is the thing to check first

  Fruit Bat /\0/\ 16:40 23 Apr 2013

The length of the power(220v) lead won't matter as the voltage drop over a long length would not drop the voltage below the "brick's" operating voltage range which is likely to be 110 - 220v.

The length of the cable to the laptop from the "brick" does matter as the output voltage is only likely to be 19v and is critical as to what goes into the laptop so a small change here can stop the machine working.

So burnt pins, loose connections, dry joints at the DC jack all give problems.

  woodchip 18:04 23 Apr 2013

Fruit Bat /\0/\ thats a better explanation

  greybeard 21:20 24 Apr 2013

Thanks for your input guys. When I said 'hard wired' Ihoped to rule out from your thoughts any problem with the power supply unit and its voltage as supplied to the laptop, measured as 19.66 volts from a unit rated at 19v. About 50 years of electronics experience, but only about 12 spent using computers means I can safely state that that isn't the problem, but not knowing enough about the way the internals of the laptop might organise its charging circuits for the battery, leads me ask if anyone can suggest a possible solution.

Woodchips thoughts about the DC jack will be a starting point, but I assumed that quote Moving the connector where it joins the back of the machine .....unquote, might have shown up any problem there. While this doesn't rule out the possibility of there being a problem with the mounting of the jack onto the motherboard, and why I think I'll have another look there, because the behaviour of the laptop is predictable to some extent, I'm expecting the problem to be further in. Regards, and thanks again, John

  Fruit Bat /\0/\ 22:04 24 Apr 2013

  1. Turn off the computer,

  2. Take the battery out

  3. Take out the power supply

  4. Push the power button down for 30 seconds.

  5. Reconnect power supply

  6. Then the battery.
    This is because sometimes the mother board gets static and this clears it and the reason it showed not charging was because it was fully charged.

  greybeard 23:15 24 Apr 2013

Hi Fruit Bat, I'm afraid that sequence didn't produce the desired result. However, what it did do was to show the battery led going out during the boot up , and the scenario described above then continues. If I close down, then power off at the wall, then power on, the condition is the same as in my penultimate paragraph in my op, with the battery light coming on, and the battery charging up.

Still puzzled, but suspect that there is a logical explanation - if only I can think what it is !


  greybeard 23:25 25 Apr 2013


Purely by chance, I booted up the laptop without a usb mouse connected ( I've been using the mouse because the trackpad is somewhat erratic through age - like me !)

There were no symptoms of battery problems for the next 10 minutes or so, until I plugged in the mouse. Within a few seconds the battery light went out, and the battery icon on the tskbar showed a rapidly decreasing charge.

The same mouse, when plugged into this laptop, shows no such symptoms, though with a much newer battery in it, that might be hiding a excessive drain by the mouse. Food for thought. John

  greybeard 17:43 26 Apr 2013


I've left the laptop connected to the wall power supply overnight, and when I booted up this am, without the mouse connected, the battery power light went off half way through the boot. Switched off, and then on, but with the battery light orange, showing partially charged, and exactly the same sequence happened.

I then left the battery to recharge, and when it had done so, tried again. This time it booted perfectly, and has been running since, about 5 hours. I tried connecting a different mouse in each of the usb sockets - no problem. I then connected the original mouse in each socket, and still no problem. So it has now been running for nearly six hours, with no sign of the behaviour that led to me posting this thread !

If, and when it starts to play up again, I'll post the symptoms.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

See iconic duo Smith and Foulkes' epic animation for the BBC's Winter Olympics coverage

iMac Pro review

Idées cadeaux pour geeks et tech addicts