Malapoa1 13:47 22 Apr 2010

Whilst I was on holiday my sons managed to download two additional toolbars (Yahoo and AVG)on my Mozilla Firefox browser. In so doing they have lost my Mozilla menu bar so that I am unable to view previous and subsquent pages or type in an URL that I want to visit. I have to search and go to a webpage by finding and clicking on in the search results. I have tried draging the offending tool bars to see if anything is hidden behind them but they will not move. I have looked for an uninstall button but without luck. Should I uninstall Mozilla and start again? Ideas please.

  Technotiger 14:02 22 Apr 2010

Try a System Restore back to before changes were made - or ...

Have a look at View>Toolbars, then your can tick or untick toolbars as necessary.

  The Kestrel 14:06 22 Apr 2010

If you left click at the top of the page, where it has files, edit etc, you will get a menu with all your toolbars showing to remove a toolbar delete the 'tick' in the box and to reinstate a toolbar put a 'tick' in the box.

  Shortstop 14:06 22 Apr 2010

Have you tried Control Panel>Add Remove Programs and tried removing from there?


  Sea Urchin 14:08 22 Apr 2010

You can uninstall the Toolbars by going to Add/Remove Programs (XP) or Programs and Features (Vista and W7) - get there via Control Panel.

  Malapoa1 19:34 22 Apr 2010

Thanks everyone but I have tried all these with no resuly - still no navigation bar No "Tools" or "View" buttons. Incidentally my wife, who has her own partition on my PC still has this bar. I think something must be blocking it.

  skeletal 19:45 22 Apr 2010

I’m going by memory from quite some time ago, so this may be completely wrong, but I seem to think there is something on the Yahoo toolbar, perhaps you right click, or something (!) that gives you the option of uninstalling it.

Don’t know about AVG.


  Sea Urchin 20:37 22 Apr 2010

Read this about missing menu bar in Firefox - but you should still be able to uninstall the Tool bars from Control Panel - are they not listed?

click here

  Malapoa1 22:00 22 Apr 2010

Thanks Sea Urchin. I found what I needed in the information on your "Click here". Problam solved. Thanks to everyone else for trying.

  Sea Urchin 23:14 22 Apr 2010

Good to hear it's sorted - thanks for the feedback.

  sheila.weston 12:07 22 Dec 2010

Many thanks, seaurchin. This helped me too!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review

How Pentagram and other design agencies aim to double the number of creative female leaders

How to speed up a slow Mac

Comment résoudre des problèmes d’impressions ?