Tiscali ADSL modem and USB 2.0 hub not working

  bigtim1 20:47 13 Feb 2005

I have been having problems recently with my Tiscali Sagem ADSL broadband modem continually disconnecting itself when I'm on the internet. It was suggested to me that an external self powered USB hub might be the answer as the power fluctuations might be causing my modem to continually disconnect.
I bought a Sitecom USB 2.0 Hub (with 4 ports) and also a Newlink USB 2.0 PCI card (host card). I plugged the host card into the back of my PC and then installed it and then attached and installed the USB hub and everything seemed to be going fine. When I came to plug my modem into it at first it detected it fine, but when I come to connect the modem fails. The lights on the modem stay on but the computer can't find it (the little triangle in the corner of the screen disappears). I then unplugged the modem and reconnected it, but again the same thing happened. I have plugged my printer into the hub and it works fine and the modem will connect to the internet if I use the PC's 1.1 USB ports. Please help if you can!!
I am running Windows XP Home.

Many thanks


  Laser157 21:17 13 Feb 2005

Although I am on Tiscali, I have a speedtouch modem and am not familiar with the Sagem. However from what I have read elsewhere, there can be problems with the Sagem.

The obvious thing to do first would be to uninstall and re-install the modem driver software.

Tiscali have some guidance on trouble-shooting here:

click here

There is also a link there to instructions on re-installing the software.

  spuds 21:47 13 Feb 2005

Tiscali supplied me with the SpeedTouch 330 modem originally, and I had problems similar to the one that you are experiencing.I also purchased a self-powered hub and card, but very little improved. Apparently the problem was well known to Alcatel/Thomson the manufacturer of the modem. It was the motherboard chipset that was not compatible with the modem. Tiscali then supplied a Sagem [email protected] 800 E2T, which was no better, even though Tiscali stated that it was the better and more trouble free product. So I would perhaps suggest that it could be a motherboard supply connection problem, similar to the one I had.

Try contacting Sagem's UK office for further help and advice. Sagem Communications UK Ltd, Knyvett House, The Causeway, Staines, Middlesex TW18 3BA or telephone +44 1784 898 158 Fax +44 1784 898 159 And let the forum know how you got on.

  Laser157 22:22 13 Feb 2005

hi Spuds

I thought this problem was only with certain Via chipsets and caused by too much power being taken by the USB port. If a self-powered hub is being used this should not be a problem.

  Laser157 22:23 13 Feb 2005

Should have said that my mobo has one of the supposedly affected chipsets, but I have never suffered the problem.

  bigtim1 22:43 13 Feb 2005


Thanks for your responses to my question so far. I have uninstalled and reinstalled my modem, but still it won't work with the USB hub. The system will recognise it, but the status of the modem will stay on not ready.

Any help will be greatly appreciated.


  Mike D 22:57 13 Feb 2005

The Sagem modem has a known problem with via chipsets, i believe. Also the modem likes to be plugged into a USB socket on the motherboard. Look in the broadband forum in the members area at click here


  Lady Lara 23:01 13 Feb 2005

Try the other ADSL Filter that came with the modem. It worked for a friend.


  ensonricky 23:05 13 Feb 2005

A firmware upgrade for the modem might be worth considering if available.

  Laser157 09:05 14 Feb 2005


Unlikely I know, but if you happen to live within striking distance of mid-Essex I could lend you another modem to try to see if yours is faulty. E.mail me if you want to do this. Alternatively have you got any friends or colleagues who could lend you one to try?

  spuds 11:00 14 Feb 2005

Hi Laser157-- Yes it is correct in what you say regarding the VIA chipset. Both my Tiscali supplied modems gave similar problems, but I have still unresolved issues on this matter. Still using the SpeedTouch with the occassional drop-out. Some days there are no problems, other days it terrible. Reference to the self-powered hub, it doesn't seem to make much difference to my set-up.I found Thomson technical very helpfull, never tried Sagem. Tiscali Broadband support was reasonable, and I find the on-line troubleshooter very limited.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

8 brilliant character artists speaking at Pictoplasma 2018

iMac Pro release date, UK price & specs

Football : comment regarder la Ligue 1 en direct ?