Thunderbird 32 won't download dictionary

  Chris the Ancient 14:53 15 Aug 2014

Been away from this site for quite a while for various reasons to complicated to go into for now!

Bear with me in the following burbles; but I want to give some background... it may help?

Lately I have changed my my much loved 'old' machine in XP to a machine running Win 7 Pro 64-bit (but still using Office XP Developer). Needless to say, the well-known incompatibility problem with Win 7 and Outlook XP (2002 version) reared its ugly head. So, I got used to opening Outlook at the beginning of the day and setting up the email password etc. A bit of a palaver, but it was only once a day.

Then... another hiccup started occurring! When I sent emails, I found that not all the email was being sent... just the first few lines of message [gulp].

Getting a bit fed up, I have loaded Thunderbird (I have version 31.0 according to the 'About').

But, I found that there is no spell checker working! There are two English (UK) dictionaries available according to the Add-ons list. But they won't download. And if I try to drag either link onto the desktop and click them to see what gives, I get the dreaded "404 - Page not found" message. Has anybody else had similar problems or found a way of actually getting a working spell check into Thunderbird?



  Batch 17:09 15 Aug 2014

I use British English Dictionary (Updated) 1.19.5 which you can download and save the installer file from here click here and then manually install.

There's what appears to be a slightly later version at V2-15, although I've not installed this.

To manually install go to Tools, Add-ons, then click on the drop down on the small "gear" symbol that is to the left of the search box. On of the options there is Install Add-on from file.

  Chris the Ancient 17:39 15 Aug 2014

Hi Batch

Thanks for getting back.

That is a dictionary that I've been trying to get going - with no success.

Clicking the 'Download' button didn't do anything but give the fault details I described. As there is only a 'Download' button, how did you find a way of getting the installer file? All I ever managed to ever get is the page 404 message? Other activities I've tried just say that the file is corrupted.

So... I don't seem to be any further ahead at the moment. And I can't find a 'sensible' way of contacting Mozilla (apart from the help forum pages - which don't).


  Batch 17:52 15 Aug 2014

Firstly, I'm using Chrome as a browser.

On the 1.19.5 page I click Download Now and get a pop-op dialogue encouraging me to install Firefox or "download anyway". I select the latter and get the Save As dialogue to save the .xpi file.

On the 2.15 page, I click on Download Now and a "How to Install in Thunderbird" pop up appears and a couple of seconds later I get the Save As dialogue to save the .xpi file.

I've also tried them both in IE and get basically the same (except getting IE's bespoke save dialogue rather than the standard Windows one).

  Chris the Ancient 19:06 15 Aug 2014

Hi Batch

I'm afaid I'm away from my 'main' computer at the moment. I'll try those ideas tomorrow... and report back.


  lotvic 22:12 15 Aug 2014

W7 32bit and Using Thunderbird 31.0 I've just installed the 1.19.5 via the Add ons menu. Didn't have any probs, I clicked on 'Install' it just installed okay.

As a note: when composing, don't forget to change it to English (GB) click on the down arrow next to spelling or rightclick in the main message area text box and choose 'Languages' and put the dot next to English (GB).

  Chris the Ancient 10:52 16 Aug 2014

Well, well, well.

Followed the guidance of Batch and lotvic this morning.

And it worked!!

I don't recollect doing anything different to that yesterday - when it said a file was corrupted - so perhaps Mozilla (or me) was having a bad day!

Many thanks guys. I'm a happy bunny again.


  Chris the Ancient 10:56 16 Aug 2014

Can't find out where the tick resolved has gone!

  lotvic 16:02 17 Aug 2014

click on any of the big grey ticks below a post and it will turn green then when page is refreshed thread is marked 'resolved'

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HTC U12 Plus review: Hands-on

Best Android emulators for Mac

TV & Streaming : comment regarder Roland Garros ?