Thinkpad E600 seems to have "lost" it's BIOS, help

  six-h 13:39 17 Jan 2011

Having installed Linux Mint 9 Lxde on it and EVENTUALLY managed to get the sound to work, and endure a re-boot, I decided it would accompany me on holiday!
Just to be sure, I also took along the Linux Disk, a thumb drive with essential files to restore WiFi and sound, and just to be sure, to be sure, ...a spare HDD with XP Pro istalled on it!
Bomb I thought!
two days in and the blessed thing just stopped working!
All I get is a crude line drawing of a Floppy drive and a disk with an animated arrow basically saying "feed me, feed me" and an instructioon to press "F1" at the same time.

The machine doesn't have a floppy drive, just a CD, and Wot disk does it want!

I have noticed in the past when installing or Firing up Linux, that it warns me (in all that geeky stuff that flashes past at the speed of light!) that it's detected an IBM BIOS EPROM, and that it may become irretrievably damaged...or something like that.
Any way, I think that it's finally happened....can anyone help me get it working again?

  Ex plorer 16:10 17 Jan 2011

My knowledge of Linux is limited but a few questions first to see if I can help, there are people here on PCA that will have better knowledge than me.

Hi you have installed Linux Mint 9 Lxde onto your ThinkPad E600.
Is there any other windows based OS on the HDD.

Is it the original HDD that will have all drivers on it?

You have a Win XP also on a HDD does it have the drivers loaded on it for the ThinkPad E600, was it loaded by the ThinkPad E600.

What happens when you press F1?

When holding down the F1 it's for cold booting (not a restart) to enter the BIOS set-up screen.

Do a Google search for the motherboard and see if you can find some instructions.

The disc it is asking for will be a Boot CD disc for the ThinkPad E600 do a search on the net and see what you can find.
Type Linux ThinkPad E600 boot disc.

Has the CMOS battery died?

  six-h 23:17 17 Jan 2011

Ex plorer; my apologies for not replying sooner, the notification system must be a bit flakey as I've not received any!
I cloned the original installation of XP Pro from the original 3.2GB drive on to a 20GB one that I had spare, because XP was whingeing that there was only 82MB of free space! lol
It ran a little better but not much, so I thought I would try wiping the original 3.2GB Drive (now redundant) and installing Liux Mint 9 Lxde on it as the sole OS.
That too worked OK, but again was a bit slow, and also complained about the lack of room!
CMOS is far as I can tell.
this machine was running using either HDD.
The XP installation was as I say, cloned from the original small HDD onto the 20GB one and there were no "driver issues".
The Linux installation was on to the original 3.2GB disk which was first wiped and again no driver issues....except the sound and the WiFi which were not supported by Mint, I had eventually sorted both these problems but this problem just came out of the blue.

>>What happens when you press F1?<<
Pressing it whilst powering on, takes me to the Time and date set screen, not into BIOS as it used to do.
Another strange thing is that it is no longer possible to enter the correct values using the keyboard, I now have to use the "track point" which moves a bloody bird around the screen flapping it's wings....I kid you not!
I don't know what those early programmers used to smoke, but I'd like some!!

The loss of the time and date is not necessarily indicative of a failed CMOS battery, it happens frequently when exiting Mint, it can be fixed, but I hadn't gotten round to doing it!
It didn't happen if the XP drive was installed because XP shut down nice and tidily!

You say it's asking for a "boot CD", it isn't.
The line drawing is very specifically showing a FLOPPY drive and disc.

The machine is not fitted with one, but I suspect that a floppy drive would be one of the few things that would function to input data when there is no BIOS present.

I have tried to boot from the Mint CD, which also serves as a bootable "Live CD", but the machine just ignores the drive.
The BIOS was set to CD as First Boot, and that seems to once more point to the BIOS being absent.
I think these Thinkpads are a breed apart, it seems there are Mac's, there are PC's.......and then there are Thinkpad's :-(

  robin_x 23:38 17 Jan 2011

Start at Esc and work your way through all the F keys at boot up.

So hit Esc twice a second while booting and see if anything comes up. Then reboot and do same with F1 etc.

If you can't boot to BIOS or CD or HDD or USB, take the machine put it away and enjoy a stress free technology free holiday.

(or go to your nearest computer store and buy a new one)

  six-h 11:16 18 Jan 2011

Hi robinofloxley, too late regarding the holiday!
It's already over. :-(
I did however manage to read 6 books in the lovely sunshine and have to admit it was much more relaxing!! lol

I'll try all the "F keys", hadn't thought of that!

  six-h 15:51 18 Jan 2011

Hmm.. robinofloxley, I've tried booting whilst jabbing each and every "F" Key, blasted machine was totally oblivious to them all....except "F7", when the screen went blank....I was full of expectation, until I realised that it was the key which usually has to be combined with the "Fn" key to send the display to a monitor!
Beginning to think it's a brick. :(

  robin_x 17:35 18 Jan 2011

I gave my old Thinkpad to my sister when she had problems. I had a new laptop, another very old laptop (Compaq Armada 11GB!! 128MB AM) and my desktop.

The ungrateful wretch took it to the recycling centre. I would have had it back. I never throw anything away.

But I think in your case it's past it. Even if you did get it working.

  T0SH 18:14 18 Jan 2011

I as I suspect this laptop is a Thinkpad model 600E, to enter bios setup Press and keep holding down the F1 key while you switch the laptop on after a few seconds it should enter bios setup where you will need to reset the clock to the correct time and date then exit saving the changes this involves moving to the reset icon clicking it then on the next screen you will get a prompt which looks a bit like "O-I" you need to confirm this by pressing the enter key to restart

the cmos battery should it require replacing is a tagged version of CR2032 fitted with wire leads and a small two pin molex plug which plugs into the motherboard this is located under the memory cover on the bottom of the laptop

Cheers HC

  six-h 18:40 18 Jan 2011

Thanks TOSH, but I've done all that...and more!
All to no avail.
As I say, the loss of Time & Date is more to do with the way that Mint shut's down, and is a known bug.
I just hadn't gotten round to fixing it!

The voracity of this is shown by the enduring Time/Date when I slip in the HDD that has XP Pro on it, and immediately I swapped back to Mint on the other HDD, I kept losing them at shutdown.

  dfh 18:53 18 Jan 2011

If you go to click here and put a search in re linux/bios it may help you solve the problem. You may need to delve a little.

  robin_x 18:56 18 Jan 2011

Sorry. It is not tap the F keys, it is press and hold F1.

And it just occurred to one of the keyboard keys stuck down? Seeing as you mentioned you had problems entering data.

Also are you really really sure it isn't date time.
Why not do as per feedback comments here.

Will only take a min to see if you can do it.

click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

WWDC history: Apple's product launches since 2005

Comment importer des contacts d’un iPhone à un autre iPhone ?