Task Host Window stopping background tasks in W10

  tallboy 14:43 21 Nov 2017
Locked

Having successfully updated my 64-bit Windows 10 desktop to the latest creator's update, I now find (following a further two small updates which had to be done separately) that I can no longer get the Windows function in the Task Bar to work. (i.e. no list of apps or tiles & in-ability to open the Settings menu.) If I shut down (having used Ctrl+Alt+Del to bring up the blue screen and Off function) I now get a message stopping the shutdown "Task Host Window is stopping background tasks. (Microsoft \Windows\Plug & Play\Device Install Reboot Required.)" I have not installed any new Plug & Play devices (unless the new post-creator update is classed as a Plug & Play device) and if I do a reboot, the same message comes up again when I switch off.

I suspect this Task Host Windows is causing the problem with the start list not showing up. How do I fix it? Suggestions please!

  Govan1x 10:18 22 Nov 2017

Have you tried running sfc /scannow in cmd to see if it finds any problems. And maybe check in device manager to see if any problems on there, Then of course try Event viewer to see what it shows.

With the latest version of windows it runs Windows defender and Windows Firewall automatically. If you have your own security on board maybe a conflict with them.

Another one that comes up is to disable fast start in power options.

No doubt you have tried most of them. Hope someone can give you the advice needed.

  tallboy 11:24 22 Nov 2017

Thanks for the post Govan1x. I ran sfc /scannow and it found one corruption - which it corrected. I then ran it again and there were no errors. Suspecting that my TV dongle might be the cause of the problem (since the Windows Host Plug / Play problem has only just shown up; I recently added Kodi which may be trying to access it in addition to TotalMedia which I normally use with it) I unplugged it. So far I haven't had the Host problem, but on first startup the programs menu / tiles don't come up and my data hard drive is unaccessible, even though I have unlocked it. (It is protected by Bitlocker.)

If I log out(using Cntrl+Alt+Del to bring up the options) and then log back in again, everything comes back to normal. I'll try disabling the fast start and see if that cures the problem as I don't think it is a conflict between Defender & KTS.

I see from Googling this problem several magazines have covered it(Including PC Advisor) so it is quite common with the Fall Creator's Update! Hopefully Microsoft will issue an update that addresses it.

  tallboy 16:35 23 Nov 2017

Many thanks for the post rdave13. I have switch off the option to use my sign-in info etc. I have also taken Govan1x suggestion to disable fast start in the Power Options. So far, so good! The problem hasn't re-appeared. Let's hope it stays that way.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro (2019) review

Magical mystery tour - Artist colourfully customises bus to promote positive mental health

Apple Streaming Service Release Date & Apple TV Subscription Rumours

Quel est le meilleur iPad ?