A take of woe - and success

  Ian in Northampton 12:50 21 Jun 2014

This is more by way of experience sharing than asking for help. You never know if any of this stuff might apply to you.

Son’s gaming PC kept freezing at random times/in random applications. When he attempted to reboot, he was getting an error message I’ve never seen before to do with the Realtek LAN controller and the client MAC address. It then went on to say that it ws exiting PXE ROM, followed by ‘Disk Boot Failure – Insert System Disk’.

My original thought – only on the basis of the Realtek/MAC thing – was that the PC was encountering some sort of network error when trying to boot.

However, I noticed that, when the PC foze, there was intense disk activity.

A little research indicated that the error I was seeing was that, as the PC couldn’t find an operating system to load, it had gone looking for one on the network – and failed.

Putting two and two together, I surmised that we had a hard disk problem, which would explain the freezing, the activity and the boot error message.

I tried chkdsk etc., but we were making no progress and things were getting progressively worse. In the end, I installed a new hard drive.

Then I encountered another problem that threw me. I tried to install XP SP1 (don’t ask why…) and the installation fell over while it was loading devices. Oh well. So I tried again. It fell over at the exact same point. This obviously wasn’t a hardware problem as such but a software problem.

Again, some more research. I was absolutely amazed to find that some motherboards – including my son’s Gigabyte board – are incompatible with XP SP1. Fortunately, I was able to find my bootable copy of XP2 (slipstreamed in) and that booted fine.

My problems didn’t end there though. First, a perfectly random keyboard failure didn’t help. Then, my 64-bit W7 upgrade disk didn’t seem to have correctly loaded all the files, and the installation fell over while it was trying to expand them. So I loaded my 32-bit Windows 7 upgrade disk, and we got there in the end.

Well, almost… He plays Planetside. The next morning, I was greeted by my son with “Planetside keeps crashing”. In fairness, he had feared this might happen. Installing 32-bit W7 only allowed him to use 4GB of his available 8GB, and Planetside is notoriously memory hungry.

So I found a backup copy of my 64-bit W7 disk and installed that. And, fingers crossed, we seem to have got there.

PCS? Doncha just love ‘em?

  [DELETED] 13:10 21 Jun 2014

Well sorted :) Easy as usual then....

  Ian in Northampton 13:34 21 Jun 2014

Thanks rdave13. Just another day in the life of a father, I guess...

  bumpkin 15:03 21 Jun 2014

Thanks for the info, sounds about par for course.

  amonra 15:35 21 Jun 2014

I hope your son realises what a hero he has got.

  Ian in Northampton 16:37 21 Jun 2014

amonra: thanks. I can dream...

  Jollyjohn 09:31 22 Jun 2014

Next time you boot up have a look through the BIOS settings. There are two places where you can change the Boot order / Boot devices. One is obvious and the second, relating to network boot is a bit less obvious. Disable them both.

I had a very similar issue with a refurbished PC I set up recently. When I had disabled both the PC booted noticeably quicker.

  Ian in Northampton 15:45 22 Jun 2014

Thanks Jollyjohn. In this case, I don't think that would have helped - it was set to boot from CD/DVD first, HDD second, then network. It couldn't find Windows on the HDD (because the HDD was broken) so moved on to try to find Windows on the network.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy Tab S5e Release Date, Price & Spec

Robert Hunter talks animating his magical storybook style for a spaced out music video

Best iPhone & iPad games 2019

Samsung Galaxy X : date de sortie, prix et fiche technique