System Restore points go missing

  PATRIOT 21:29 21 Jul 2008

Hi, My PC's OS is XP Home (service pack 3) with a single patitioned 160Gb HDD (50 Gb free space, Security programs include: AVG free, Windows Defender, Zone alarms (basic). Spybot S&D was removed a week ago.
I tried restoring after MS update KB951748 clashed with Zone Alarms and discovered that all my restore points were missing.
Event viewer showed that SR was not working for at least two weeks before that. Unfortunately Event Viewer only goes back to 22th June, the day before I added 2 Gb DDR2 Ram to the 1 Gb already installed. So I can't tell if adding the Ram caused the problem or if it was already a problem.
I have: removed the extra Ram, Manualy turned off and on System restore, and set restore points only to see them dissappear on the next day's boot and within a couple of days.
I have removed 4Gb of images from My Documents to an external HDD but still I can't rely on System Restore. Event viewer show that System Restore is suspended because there is not enough disk space available on the system drive. To restart System Restore, ensure at least 200 megabytes (MB) of free disk space are available on this drive.
Any help welcome.

  Ditch999 22:18 21 Jul 2008

Make sure it is running in Services. Go to Start?Run and type in
Make sure it is set to Automatic and is running. Make sure RPC is also set to Auto and running.

  PATRIOT 21:09 22 Jul 2008

Hi Ditch999, both were set to Automatic and are started. I notice that RPC Locator is set to manual. When I booted today, and up to now, SR is still working and I still have the restore point avalable that was created yesterday. Normally they will be lost by the third day.

  €dstowe 21:57 22 Jul 2008

Do you have both partitions set to be restored?

I have found that on multi-drive or partitioned systems that System Restore is unreliable at best, but normally totally useless.

You only really need to be able to System Restore your "C" drive so disable to process on any other drives you have - including external ones.

  citadel 22:38 22 Jul 2008

in system restore settings move the slider along to max.

  PATRIOT 22:59 22 Jul 2008

Hi all,
€dstowe - There is only one drive and no partitions.
citadel - The slider is hard to the right (max.).
Some months ago I swapped my 40 Gb system drive for the 160 Gb drive currently in use. Acronis was used to achieve this. I had to re-register Xp by phone and all went well for many months. Could it be that Windows still 'thinks' it's on the smaller drive?

  Les28 10:06 23 Jul 2008

A couple of points, did you turn off system restore before you used Acronis to clone your old hard drive a couple of months ago? If you didn't, do you know if system restore has worked since then on the new hard drive ?
I was wondering if you didn't turn off system restore before the cloning you may find that the drivetable.txt file inside the Restore folder which is inside the System Volume Information folder on C drive root contains references to your old hard drive. In that case, I think I'd be inclined to turn system restore off to purge your old restore points, rename drivetable.text, reboot, then turn system restore on, leave the machine running for at least 15 minutes, check that a new drivetable.txt has been created, then create a restore point and see if that sticks.Have a look here will explain how you have to give yourself permissions to open the SVI folder, I usually do the permissions thing in safe mode.

click here

If you did turn system restore off before cloning the drive, maybe we'll have to look for another solution.

  PATRIOT 22:16 23 Jul 2008

Hi Les28, Thanks for your input. No I didn't turn off System Restore before cloning last November,& I am sure that I have used Restore since then.
I have tried what you have suggested and now will wait a few days to see if it has cured the problem.
I'll be back....

  PATRIOT 22:45 26 Jul 2008

Neary 4 days. So far so good.

  PATRIOT 13:21 27 Jul 2008

It was one restore point too many today. Setting a restore point today wiped all the previous ones.
I am back to square one on this. Any one with similar problems or solutions?

  Les28 14:36 27 Jul 2008

Hi PATRIOT just when thought maybe getting somewhere, only thing I can think of now is do you use the latest version of windows defender, not the beta version as I've read about this older version creating multiple restore points every day that wipe out windows system restore points and generally causes system restore problems. Programs that create their own system snapshots can cause these kind of problems.

Are you still getting the message in event viewer that system restore is suspended as there's not enough space allocated to it? Les.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

Best Keyboards for Designers & Artists

What to ask Siri on the HomePod

Meilleurs VPN (2018)