System Restore not successful.

  Plotholder 20:15 04 Jan 2012

After unable to connect to my wireless network, I did a restore - but got a message: System restore failed to replace the file (C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking\98c An unspecified error occurred during System Restore (0x80070002)

I've tried 3 restores to get the same message.

Am at a loss to get the computer back on line.

Running win7 (32Bit) with Norton 360.

  difarn 07:20 05 Jan 2012

Did the connection fail after an update or after downloading any application?

Can you connect to your router via ethernet cable?

This seems to be in relation to a homegroup set up and a corrupted id file - have a look at this article which should help.

  Plotholder 16:56 06 Jan 2012

Did not work. In view network get "The Dependency service or group failed to start. On trying to connect to the internet, get an horror "Windows did not detect an network hardware".

All went down when the system was accidently switched off at the mains.

  difarn 00:04 07 Jan 2012

It may be that you need to update the drivers for the ethernet controllers.

If you have access to another pc with internet access and a usb stick try to update the relevant drivers from the manufacturer's website unless you have a driver disc that came with your pc.

Could be a corrupt TCP/IP stack:-


Start > All Programs > Accessories > Command Prompt (Right-Click and Run as Administrator)

At the command Prompt type: netsh winsock reset

Ignore all errors, restart your computer

  Plotholder 15:45 10 Jan 2012

Did the TCP/IP stack and got the message "Initialization function InitHelper.dll in Nshhttp.dll failed to start with code 10107" but still did a restart but no difference.

Before that did a fault detection-network diagnostics log: D011FE22A9D8AD5.Diagnose.Admin.0.etl Other networking configuration and logs - Filename:

  difarn 17:16 10 Jan 2012

Have you been into Device Manager and clicked on Network Adaptor /Ethernet Controller and see if they are listed. If so, right click on Properties and try to update drivers - if nothing is listed it may have been because of a power surge when everything got switched off - re-install drivers.

If this doesn't work

Try : for Vista and XP

Go to Control Panel -> Administrative Tools -> Services -> Right-click on DHCP Client and select properties -> select the "Log-On" Tab and verify "Local System Account" is selected and nothing else.

If you are using windows 7 - start - type in services and navigate from there.

  Plotholder 00:12 12 Jan 2012

All the network adapters report the same - 11 of them - that windows can't load the drivers (Code 31).

  difarn 08:02 12 Jan 2012

This error happens because of a dependency on another device.

Do you have a disc with the drivers on? Have you tried reinstalling these?

If not:- First step - download a new driver for your network adaptor, uninstall the present one and reinstall the new one via update drivers in Device Manager - when given the prompt about where you want the driver downloaded from click on file on pc - navigate to it and click.

If this doesn't help:-

Try: Click on start - all programs-acessories and right click on command prompt - select "Run as Administrator" to open a command prompt.

To reset IPv4 TCP/IP stack to installation defaults type in:- netsh int ipv4 reset reset.log -press enter Then reset IPv6 TCP/IP stack to installation defaults type in:- netsh int ipv6 reset reset.log - press enter Then reset WINSOCK entries to installation defaults netsh winsock reset catalog - press enter

Restart the computer.

Then - start - in search box type cmd - press enter - choose "run as admin"

From the black screen type ipconfig /all NOTE the space after the g and the / press enter

Does this work?

  Plotholder 16:43 15 Jan 2012

Phew - Back on board. Thanks a million for all your help. It has also made me appreciate my little netbook...... Thanks again

  difarn 18:45 15 Jan 2012

Glad to help and that you are sorted. It is really necessary to have a spare PC in situations like this.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator of witty, relatable Instagram comics Julia Bernhard touches on our humble moments

iMac Pro review

Quelle est la meilleure application de podcast pour Android (2018) ?