System Restore Doesn't Work After Last Critical Update

  RegScriv 09:04 18 Aug 2014

Microsoft's last critical update seems to have caused a number of problems, one of which is that my System Restore now doesn't work. I tried to restore after the update caused problems with connecting my Nexus 7, but none of the available restores worked. The dialogue box stated that maybe I have a disc error, but scandisc found nothing. Can anyone help.

  Batch 09:07 18 Aug 2014

I know this does't help you immediate problem, but the lack of reliability of System Restore is one of the reasons I make frequent complete images of my system partition (which is just OS and pgms). I feel much more secure with complete images (not incrementals) and I have always turned off System Restore and used the images instead whenever I need to roll back.

  RegScriv 09:52 18 Aug 2014

I agree and take frequent images of just the OS&prms - C drive just as you do. I'm using Macrium Reflect which I switched to when upgrading to Windows 8.1 (Acronis was reputed not to work with W8.1) and it looks like I'll have to use restore using it now. Problem is if this latest Windows update installs and causes the same problem again. I don't want to switch off Automatic Updates.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Google Home Hub review

Print legends Dan Mumford and Supermundane on making the leap from 2D to AR

How to watch Apple’s October 2018 iPad launch

OnePlus 6T : date de sortie, prix et autres rumeurs