svchost.exe rorros and STOP error - aarrgghhh

  sam1981 13:36 16 Dec 2003

My relatively new (about 2 months) Dell Inspiron 500m has started playing up badly.

Everynow and then I get an error telling me:

svchost.exe - Application Error

The instruction at "0x77f944b1" referenced memory at "0x016207bc". The memory could not be "written"

Click ok to temitae the program
Click cancel to debug

It also sometimes said that the memory could not be "read".

It then occasionally comes up with the following stop error:

*** STOP 0X0000008E (0XC0000005, 0X80534DE3, 0XEEECFA40, 0X00000000)

I've searched around on the knowledgebase and on google and I've seen it suggested that it could be a device driver, but I'm not sure which one (if any). The stop error does suggest updating the video driver, but that didn't fix matters.

Any thoughts, suggestions?

  johnnyrocker 13:37 16 Dec 2003



  sam1981 13:38 16 Dec 2003

XP pro

  johnnyrocker 13:41 16 Dec 2003

no prob, if a very recent error why not try system restore? where did you upgrade the video driver from? (if microsoft and nvidia card it does not work)


  sam1981 13:47 16 Dec 2003

It started hapenning last week I think, maybe earlier (it's not actually my machine, it's a user at work's) so it's not that recent.

I upgraded the video driver direct from Intel.

I noticed that the wireless card icon in the taskbar had a red cross through it despite me not disabling it so it may have been playing up. I've disabled the device (as it's not being used right at this moment) to see if it helps the prob.

  rawprawn 15:28 16 Dec 2003

Try System File Check. Put the XP cd in the drive, let it auto run & exit, now go to start/run and type sfc /scannow this will scan for altered or missing files & should hopefully solve your problemPut the XP cd in the drive, let it auto run & exit, now go to start/run and type sfc /scannow this will scan for altered or missing files & should hopefully solve your problem ( if it asks for the cd at any time press OK )

  rawprawn 15:30 16 Dec 2003

Don't know how I managed the instructions twice.

  sam1981 15:32 16 Dec 2003

I have actually tried running 'sfc /scannow' when I first started looking at it this morning, but I kept getting a stop error halfway through it.

I will try it again though now you have reminded me.


  s3mt3x 16:33 16 Dec 2003

Isn't svchost.exe the Remote Proceedure Call worm? As far as I can remember this is the executable file the worm occupies. Perhaps a search on google for "RPC worm fix" may lead to sorting it out.

  sam1981 16:45 16 Dec 2003

I've updated the wireless NIC driver and then I ran sfc /scannow again and it managed to get all the way through, but while I haven't seen the svchost.exe error come up for a few hours, the STOP error just has occured again.

s3mt3x, the machine is fully up to date with the latest windows patches which I thought included that RPC DCOM security issue. I've also scanned it with the latest McAfee DAT files and nothing has come up.

  s3mt3x 16:46 16 Dec 2003

How many instances of svchost are running in the task manager after you connect to the web?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review: Hands-on

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?