Sudden error plethora!

  Thurrafork 13:41 27 May 2010

Hello folks
Suddenly having a host of peculiar problems with my machine, which has up to now been perfectly stable since I built it back in October.
First of all it randomly started bluescreening the other night - ran WhoCrashed and it analysed the minidumps and said ntoskrnl.exe was to blame. Didn't really know what to do about that so after faffing for ages with system restore (which suddenly didn't work for various, possibly connected reasons) I opened the case and saw that the restraining clip on one of my RAM sticks had come undone - the stick itself seemed properly seated, but nonetheless after clicking the clip back into place I have had no further bsods.. yet.
But now I keep getting:
Faulting application name: svchost.exe_SysMain, version: 6.1.7600.16385, time stamp: 0x4a5bc3c1
Faulting module name: sysmain.dll, version: 6.1.7600.16385, time stamp: 0x4a5be07e
Exception code: 0xc0000005
Fault offset: 0x0000000000004737
Faulting process id: 0x3ec
Faulting application start time: 0x01cafd9242d3e679
Faulting application path: C:\Windows\System32\svchost.exe
Faulting module path: c:\windows\system32\sysmain.dll
Report Id: aaa34dfa-6989-11df-a926-00241dcd86d3

Followed by (possible triggering) a cascade of further errors:
Windows Audio Endpoint Builder, Offline Files service, Network Connections service, Program Compatibility Assistant Service, Superfetch service, Distributed Link Tracking Client service, Desktop Window Manager Session Manager service, Diagnostic System Host service, Windows Driver Foundation - User-mode Driver Framework service .... all terminating unexpectedly.
I'm running Windows 7 64bit, on i7920, Gigabyte ud5, 12gb Corsair ram, 3x wd 640gb caviars. Nothing overclocked.
Any ideas????

  gengiscant 14:03 27 May 2010

The error 0xC0000005 is generated by an illegal "memory access violation". This can be caused by anything from faulty RAM, an incorrect/corrupt device driver, poorly written/updated software.
Try removing and reseating your sticks of ram, you could run memtest click here overnight is best.
Post back.

  Thurrafork 16:11 27 May 2010

Thanks gengiscant

The general extravaganza of seemingly unrelated errors I've been getting over the last couple of days does make me think faulty RAM too - which is always annoying!
I ran memtest for days back after I'd built it and all was well, but I guess problems can develop. I'll run memtest again as soon as I can.

Another couple of errors over the last hour or so. Both causing Internet Explorer to crash. With one the faulting module was ntdll.dll, with the others it was jscript.dll.
Ooh, and then I had the old "Display driver amdkmdap stopped responding and has successfully recovered." Obviously relating to my 5850 ati card - haven't had that error in a while!

I'll test memory when I can, but in the meantime are there any other suggestions?


  gengiscant 16:49 27 May 2010

I was up until a couple of day ago was getting random BSOD,s I posted here about it click here
I changed the DVD/CD optical drive and, touch wood, I have not had a BSOD since.Its only been a couple of days but its looking good.

So I suggest checking all cables/cards are seated,it not the first time I have loosen a cable whilst doing something else, running memtest,though of course it might not necessarily show a fault even if this is one.

  Thurrafork 01:52 28 May 2010

Oh no!
I thought it was just these minor errors I had to deal woth now, but then I suddenly had a couple of BSoDs - similar to the initial problem!
The WhoCrashed log is the same as the previous recent BSoDs:

On Fri 28/05/2010 00:42:36 your computer crashed
This was likely caused by the following module: ntoskrnl.exe
Bugcheck code: 0x1A (0x41790, 0xFFFFFA80056B9DA0, 0xFFFF, 0x0)
Dump file: C:\Windows\Minidump\052810-22807-01.dmp
file path: C:\Windows\system32\ntoskrnl.exe
product: Microsoft® Windows® Operating System
company: Microsoft Corporation
description: NT Kernel & System
The crash took place in a standard Microsoft module. Your system configuration may be incorrect, possibly the culprit is in another driver on your system which cannot be identified at this time.

As I said before I'll run memtest when I can spare the time, but please any other ideas?? I looked to Restore again only to discover that all restore points earlier than yesterday have been lost. It's like the Gods don't want me to sort out this problem!! ;)

  gengiscant 08:39 28 May 2010

Have a look at here
But I really think you have ram problems.

  Thurrafork 12:12 28 May 2010

Thanks again gengiscant,
I should be able to put aside a full 12hrs over the weekend in which to run memtest - I'll let you know what it shows.
I agree that RAM is probably the culprit, but for some reason I expected that memory going from fine to faulty (I ran memtest extensively after I built the machine back in October - it was fine) would manifest as a gradual increase in errors/crashes. Whereas my machine has operated with complete stability until the evening of the 25th when BSoDs very suddenly started! I hadn't installed any new soft/hardware on this date either.
But yes, can RAM fail with such immediacy?

  gengiscant 12:30 28 May 2010

What make of ram are you using?
In an ideal world we would have spare ram to swap to rule out or not problems in this area.
I was doing a spot of overclocking this morning and low and behold I started to get BSOD's and according to bluescreen view 4 of the 5 had a similar error with ntoskrnl.exe.
I know there is nothing wrong with my ram, these ridiculous error codes/messages which are no help to anybody are pointless.
You Google any error code and you are guaranteed to find some saying it might be bad ram.
Anyway I have toned down the overclocks and every thing seem to be running fine.

  Thurrafork 13:02 28 May 2010

My ram is Corsair.
Really? You're suddenly getting these as a result of overclocking?
Trouble is none of my components are overclocked.

ntoskrnl.exe was identified by using WhoCrashed to analyse the minidump. In event viewer it says the problem is Kernel-Power event ID 41. But the salient words on the Blue Screen were MEMORY MANAGEMENT.
So thats three different phrases attached to the same crash.
I don't know what's up.
And beyond this I'm still getting lots of other errors:
Fail to parse XML file.
Reason A string literal was expected, but no opening quote character was found.

Line 0x000001c9
Position 0x00001d75
Errorcode 0xc00ce502
Problem text <FILE_LIST path="c:\windows\syswow64" filespec="atiumdag.dll" filespecBackupType="3855"/><FILE_LIST path="c:\windows\syswow64" filespec="audioeng.dll" filespecBackupType="3855"/><FILE_LIST path="c:\windows\syswow64" filespec="ctedasio.dll" filespecBackupType="3855"/><FILE_LIST path .... this error readout continues in this vain.

Related to that is:
Volume Shadow Copy Service error: Internally transferred WRITER_METADATA document is invalid.

PrepareForSnapshot Event

Execution Context: Writer
Writer Class Id: {e8132975-6f93-4464-a53e-1050253ae220}
Writer Name: System Writer
Writer Instance ID: {057e8e7b-0ffc-4452-949f-290351c74e9f}

And various other errors - don't want to bore you!


  gengiscant 14:08 28 May 2010

no problem

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

ManvsMachine and other artists put Apple's iMac Pro to the test using powerful rendering tools

What to expect at Apple's 27 March education event

Comment filmer l’écran d’un iPhone ?