Struggling to diagnose hard drive fault

  wobblymike 22:44 06 Jan 2006

I have just purchased a Fujitsu MPG3409 40 GB HDD. I installed it in my test machine as a master drive and formatted and partitioned it using a hard drive utility Maxblast which I have been using for years.
At the conclusion of the process the programme advised that in order to utilise full capacity it had installed the drive with a DDO (Dynamic Drive Overlay). This is most odd because this is normally only done when a very old MOBO is used which does not recognise HDD above 32GB or when a drive is capacity clipped. Neither is the case here. I then ran PC Check which is an industry standard test programme - it reported an unknown 8.45GB hard drive installed (there is only the drive in the PC) as well as a 40GB drive. When trying to load an OS as soon as it gets to the point where it normally says Press any key to boot from CD - it simply boots from the CD without asking the question this means that when it gets to the point where it is ready to boot from the HDD it simply repeats the reboot from CD. I have tried it as slave as well as master and each time I format it loads the DDO. This is a strange fault but just to finally prove it I fitted a 80GB drive to the PC, went through the same process and it all works as it should. Can anyone suggest what might be amiss here and suggest how I can delete everything and start from scratch. I have tried a Win 98 boot disc, maxblast, seagate disc wizard - no joy.

  Chegs ®™ 23:02 06 Jan 2006

I had similar hassles putting a 15Gb Quantum Fireball into a Dell Dimension 8100(not with partitions or formats though)

I had the PSU on my daughters PC expire,so decided that I'd bung her HD into the Dell until I could replace her PSU.To cut a long story,I couldn't get XP to continue setup from its "reboot in 10 secs" after the initial "copying files" had completed,the Dell would reboot then resume right from scratch "copying files" I was offered the "Press a key to load CD" which if I ignored produced an "NTLDR missing.Press a key to restart" message.I put the HD jumper on every set of pins,I moved the drive from end plug of grey IDE to middle and tried each jumper position again.After many hours,I stuffed an old creaky 2Gb drive into the Dell and the XP installed straight off,only issue with it being it was now loaded as D:\Windows.So I stuck 98se onto the 2Gb as I still enjoy poking around with that OS.

  DieSse 23:08 06 Jan 2006

MaxBlast is degined for MaxTor drives - and could be producing odd results on a drive where it doesn't recognise the drive geometry (or electronics) correctly (because it's not to a MaxTor standard.)

Just try it with standard Windows partitioning and formatting tools. Try running

fdisk /mbr

first, to reset the mbr, which should get rid of the DDO.

  wobblymike 23:21 06 Jan 2006


I have tried your suggestion - it reports MBR not updated and then when I try to run fdisk it reports errorreading fixed disc

  wobblymike 23:28 06 Jan 2006


The above was the case with the drive set as master - I have just tried it again as a slave and it worked to the extent that fisk /mbr worked and fdisk gets me into the options page what does this tell me?

  wobblymike 23:34 06 Jan 2006

Following on from the above I have just tried the drive configured as a slave drive and when attempting to load the OS I now get the option to press any key to boot from CD and it works as it should.

As soon as I revert to master the problem returns.
I'm stuck any help gratefully received.

  DieSse 23:38 06 Jan 2006

*fdisk gets me into the options page what does this tell me?.

Delete all the existing partitions - then create a new one - then format the drive - but not with MaxBlast.

or try the Fujitsu *pseudo low level format* utility here FJ-IDE click here

To rest the drive - then fdisk and format.

  wobblymike 08:35 07 Jan 2006

DieSse, guys

Tried the above no change - it seems it works as it should when configured as slave but not as master but in both it still loads the DDO after formatting.

Any thoughts please

  DieSse 09:30 07 Jan 2006

It won't load the DDO if you clear it with FJ.IDE and fdisk and format with the standard Windows progs (not MaxBlast).

It can't as the DDO shouldn't be on the drive any longer!

  wobblymike 09:33 07 Jan 2006

ok but if I use a win 98 boot disc will it handle a 40 gb drive?

  wobblymike 09:34 07 Jan 2006

What am I talking about as I said before in master drive config it won't fdisk

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?