Strange Issue With PSU on Dell Studio 1537

  Red Devil 19:40 12 Sep 2013

Hi all,

OK, I know this particular laptop is a bit long in the tooth but I was given it in a non-functioning state and told that if I could fix it I could have it.

Well, fix it I did - turned out it was a duff HD and duff battery.

I decided I wanted to upgrade the DVD to a BluRay as Overclockers were selling an internal laptop BluRay cheap.

Me being the brain surgeon that I am I managed to break the connector on the motherboard for the touchpad.

I ordered a new motherboard and fitted that yesterday. Everything seems OK apart from this weird problem with the power supply.

I have the mains adaptor connected. It's a genuine Dell 1537 AC adaptor.

The power indicator LED doesn't illuminate. The power indicator on the desktop says my battery is not being charged (my battery is at 84% atm). The Dell BIOS upgrade that I downloaded from the Dell site won't run as it says I have no AC adaptor connected. Neither will Windows Vista SP2 install for the same reason.

This would indicate that there is no AC input.

However, my battery indicator has remained at 84% for 12 hours now with the adaptor connected and turned on. The battery indicator on the desktop indicates I have 3356 hours of battery life remaining. When I turn off the mains supply this time drops to around 3 hours of battery life.

To me that tells me my laptop is running off the AC adaptor but that my laptop thinks that it isn't getting a DC supply.

I am wondering if I somehow damaged the internal DC Jack lead when I was taking the laptop apart and reassembling it. Also, the motherboard I fitted is a different - later - revision of the 1537 so am wondering if that might be the cause (possibly an incompatibility between the new revision MoBo and the older revision hardware that was in the laptop when I got it?)

But I do know that the Studio 1537 has other issues so am posting this in case anyone else has encountered this issue too and had a different solution.

Many thanks,


  woodchip 19:48 12 Sep 2013

Have you tried taking the battery out and running from Mains

  Red Devil 19:56 12 Sep 2013


Hadn't thought to try that lol.

Just have, though, and the laptop boots up no problem.

The PUS indicator LED is still not illuminated and I get the message that "no battery is detected" desktop power indicator.

Many thanks,


  woodchip 20:35 12 Sep 2013

Well you will not get the above without a battery in, but sounds like Faulty Battery. as it boots and runs okay without it

  onthelimit1 08:21 13 Sep 2013

Dell laptops can be funny if the battery isn't genuine Dell. If the charge level stays high when in use and plugged in, I wouldn't worry about it.

  Red Devil 10:21 14 Sep 2013

Hiya guys,

Thanks for the responses.

Just 2 things I should probably clarify. :)

The battery is a genuine Dell battery and was recognised by the previous MoBo before I broke the connectors.

The laptop does still run off of the battery when the AC adaptor is turned off so I am pretty certain it isn't a faulty battery.

Many thanks,


  Fruit Bat /\0/\ 10:31 14 Sep 2013

Laptop Battery not showing Charging 1. Turn off the computer, 2. Take the battery out 3. Take out the power supply 4. Push the power button down for 30 seconds. 5. Reconnect power supply 6. Then the battery.

Should now show 100% charged / charging. This is because sometimes the mother board gets static and this clears it and the reason it showed not charging was because it was fully charged.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HTC U12 Plus review: Hands-on

Best Android emulators for Mac

Comment utiliser l’Apple Store Éducation ?