Start up issue after removing Antivirus XP 2010

  Chris Webster 15:42 16 Mar 2010

Hi again,

Last night with the help and advice from the forum I managed to get rid of Antivirus XP 2010 click here on a friends computer ( XP Home )

Everything seemed fine with it after numerous restarts and rescans with malwarebytes, ad-aware and avg free.

He used it for a while last night and it was running fine. This morning when he started up his computer a window came up saying,

RUNDLL Error Loading C:\windows\umosaqith.dll The specific module could not be found.

Is there a fix for this error please?

Regards, Chris.

  Fruit Bat /\0/\ 16:00 16 Mar 2010

umosaqith.dll was probably part of Antivirus XP 2010 and your machine is trying to still run it.

Have a look in startups and untick any unkown programs or better still run CCleaner click here and get rid of all junk files, use the registry tool to clean the registry and use the startup tab to stop unwanted programs from running at start up.

  Chris Webster 16:12 16 Mar 2010

Thank you for the info.

Do you mean startups in msconfig or ccleaner or both?

I did run ccleaner on the clean up setting and on the registry setting too last night but never thought to look in the startup setting.

I won't be seeing him until tomorrow so I'll leave the thread open for the time being.

Regards, Chris.

  Fruit Bat /\0/\ 16:41 16 Mar 2010

I always run CCleaner's tools several times until it stops finding anything to clean

  Diemmess 17:34 16 Mar 2010

I tried to help a friend with Antivirus XP 2010 and cleared it as I thought.
Suffered exactly the same error as you are now finding,

Another brighter friend cleared it using Doug Knox's website with a specific file or method which fixed it at last

Sorry I cant be more specific, at this stage, There is a fix on that site which works.
I hope someone else recognises this and can lead you out of this problem.

  Sea Urchin 18:18 16 Mar 2010

The virus interferes with the running of your anti-malware programs by inhibiting executable files. The Doug Knox "fix" restores the default association for .exe files to enable them to run, but you have to move fast before the virus stops it again.

click here

  Chris Webster 21:31 17 Mar 2010


I ran ccleaner on the registry clean up and sure enough 'umosaqith.dll' came up.

Now seems to be starting ok.

Many thanks, Chris.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Wacom Cintiq Pro 24 and 32 review – hands-on

When is the next Apple event?

Qu’est-ce qu’Amazon Prime ?