GM 09:23 14 Dec 2005

I have a problem every time I start my pc. I get a message saying "no signal" on screen, upon reboot a message saying windows did not start continue with normal, safe mode etc.
A message appears saying problem with driver nv4_disp. Device driver in a loop and other references to beginning to dump physical memory. OS is Windows xp home.
Any help would be greatly appreciated.

  MichelleC 09:54 14 Dec 2005

Try a 'repair': click here

  Gongoozler 10:04 14 Dec 2005

nv4_disp.dll is a part the nvidia graphics driver, so the first thing to try could be an update of that click here, but it doesn't work for everybody click here

  GM 09:59 17 Dec 2005

I tried the Nvidia driver upgrade but that did not work although it was newer than the one I already had. I am still having the same trouble with the " no signal " screen at start-up. Any more ideas?

  Gongoozler 10:35 17 Dec 2005

Hi GM. Have you had a look at my second "click here".

  GM 16:14 17 Dec 2005

I did print out and tried to go into the registry but I did not get what I expected to see so I was a bit reluctant to carry on.I did download the the Direct x 8.1 to use but perhaps you could rud through the details as when I went into regedit and put in ditectx it opened loads of files but nothing was actually highlighted so I was reluctant to delete anything. Perhaps you could give me some more help there.
What is it that is causing the loop with the nav_4 dll file which stpops windows from loading.

  Gongoozler 09:55 18 Dec 2005

Hi GM. I agree, it does look scary, an if you get it wrong you could cause even more problems. I don't have any personal experience of this nv4_disp.dll error, so I can only help by trying to interpret the instructions on the site I linked to. Before we go down that route, can you remember what changes you made before the problem started?

  GM 10:55 18 Dec 2005

Hi Gongoozler This problem has been going on for a long time and steadily getting worse over a couple of months and the only changes I have made to the computer was adding a USB 2.0 board but the problem was there long before that.Also I have added Registry Mechanic but only a week ago or so and again the problem was already there. The graphic card is a Geforce FX5200 which was installed at about the time this all started so I assume that this may be the root of the problem in some way.

  Gongoozler 16:49 18 Dec 2005

Hi GM. I'm sure that installing the FX5200 was the root of the problem. The troublesome file is associated with Nvidia who make the FX5200 chipset. Searching via Google reveals that some people have had a lot of trouble with the Nvidia drivers, so I assume that there are certain combinations that cause this problem. The forum that I linked to seems to have come to the conclusion that DirectX 9 is involved in the problem which is why all references to DirectX 9 need to be removed and then DirectX 8 installed. This is tricky because normally it isn't possible to go back to a previous version of DirectX. If you don't want to edit the registry, your alternative solution might be to get an ATI graphics card, and perhaps sell your Nvidia card on Ebay.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HP Envy x2 review: Hands-on

Iconic New York graphic designer Milton Glaser on his uplifting new subway posters

New iMac Pro release date, UK price & specs rumours

Comment suivre le parcours du père Noël ?