Staples and Lexmark z45

  concretepigsy 12:06 26 Oct 2003

I bought a lexmark printer from staples, installed fine workd for a couple of days, now every time i boot up my pc, the printer shows up as an unknown device. I have tried reinstalling drivers but every time i try and print a word document, i get the message pc not communicating with the printer. I have checked and exchanged usb cables and ceverything is nice and tight. Any ideas or is the printer broken??
I am using Windows 2000 Pro. can I have a quick response before i drive back to staples.

thanks guys

  pj123 12:17 26 Oct 2003

I had the same problem with my Epson USB printer. The Epson Helpdesk said. "Don't switch the printer off". Following their advice I don't switch my printer off and I have not had any problem since. Might work with Lexmark?

  spuds 14:18 26 Oct 2003

If you contact Lexmark, they can send you a check list, which provides a route if the printer mechanics are faulty.Very easy and simple to do.

On the USB connection, is this via a self-powered hub or multi port hub or is the connection straight into the computer socket.Lexmark state, that it must be a direct connection into the computer.I had this problem with my Lexmark X85 and X5150, and after transfering to a direct connection, most of my communication problems were solved.

Contacting Lexmark by telephone can be an 'on-hold' delay situation, so be prepared, and select a good time span. Contacting by email or fax, can also have problems.As they have had some recent 'lost' emails situation.I found the email service is either fast response or very slow, to the point of non answer. Taking the machine back to Staples,will possibly result in a replacement [if they have stocks]. Which may still not solve your problem, unless you contact Lexmark.

Sorry to sound gloomy, but I went through the try this, try that situation. Eventually all turned out okay.

  concretepigsy 15:25 26 Oct 2003

thanks guys i got a new one from staples and a £15 refund for all the bother. not bad huh just hope it workd now

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Moto G6 Play Review: First Look

iPad 9.7in (2018) review

Comment utiliser Live Photos ?