Speedtouch 330 problem

  Quiet Life 14:34 04 Oct 2007

(Posted in Networking without response and now closed there)

I have been trying to connect to my ISP with the 330 but receive Error 678 cannot make a connection. Downloaded latest software and the Error is 721 still "cannot make a connection".
If I substitute my DG834G I connect immediately so the line and connection are OK.
All the lights and diagnostics on the 330 are OK but at the end it fails to connect.
It worked OK before with the software I have but for some reason it will not now connect to the ISP. I am running XP Pro with updates and no firewalls.
Suggestions appreciated

  howard64 15:11 04 Oct 2007

if it is a usb device you may have to remove all of the driver prog from add/remove progs then reboot and install the software with the usb modem unconnected. Only connect it when the prog asks for it.

  Quiet Life 15:18 04 Oct 2007

I have uninstalled and reinstalled with ISP's software and also Alcatels in that way but it will not connect.

  daxian 15:28 04 Oct 2007

hi there.....
have you tried useing a dial up connection with your username and password ??.....your router has them built in ....but the 330 needs to use the dial up connection to sign in to your isp....Dave.

  Stuartli 15:49 04 Oct 2007

Are you using the latest drivers (which also covers Vista and Up to 8MB)? See:

click here

  Quiet Life 16:09 04 Oct 2007

daxian . Yes I use the dial up connection.
Stuartli . Yes I have one machine with these latest drivers on it. This software gives the 721 error message.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

HomePod review

Comment regarder les Oscars 2018 ?