Sony DRU500A suddenly started to writeV. Slow!

  Telyob 11:05 20 May 2003

Hi Guys,

I managed to buy a Sony DRU500A, by paying over the odds :o(, but after a few weeks it suddenly started to write very slowly, now takes 12+ mins to write a 700MB CDR and well over an hour to write a DVD. I'm also make a nomber of coasters, DVDs are too expensive to keep doing this!

When I first installed it it would write a CDR in about 4 mins and a DVD in 40 mins, at 1x as that was the only DVD-Rs I had. Then I went away, for work, for 3 weeks and the computer was being used by the rest of the family during this time, when I returned it had started to go slow.

I have tried everything I can think of but no luck yet, but I think that it is because I can't enable DMA mode on the drive.

I Tried running Nero without background applications, 12 mins to burn 699MB CDR, approx 8x speed. Tried to change it in Device Manager, IDE Controllers, to use DMA mode but it will not change from PIO! The box is set to use "DMA if available" but it does not change. The Pioneer DVD drive on the same IDE channel is in "Ultra DMA Mode2" and the hard drive on the other channel is in Mode4 but in Device Manager the SonyDRU500A will not change from PIO. The BIOS setting is Auto for the UDMA mode, there are only 2 options in the BIOS, Auto or Off.

Tried Nero CD Speed and obtained Max 8.8x with all available types of CDR, this is not good enough!

I flashed the BIOS with the latest version, KT7a9, I also installed the latest VIA 4in1 drivers, VIAHyperion4in1446vp6.exe, and re-flashed the 2.0e firmware in the Sony, and upgraded the Nero software to, all with no change to the burn speed.

I suspect that the problem relates to the drive being in PIO mode and it will not be right untill I find a way to make it work in DMA mode.

How can I force it into DMA mode, and what could have made it unable to change

Any ideas guys?



AMD Athlon 1333
512MB Ram
550W PSU
2x80GB IBM HD as Raid array IDE Raid CH1
2x45GB IBM HD as 2 drives IDE Raid CH2
1x 27GB IBM HD IDE Primary Master
Sony DRU500A as IDE Secondary Master
Pioneer 105F as Secondary Slave
SoundBlaster Live 5.1 Platinum
Matrox Marvel G400 Graphics/Video
Pinnacle Firewire Card
Windows XP Pro + SP1 and all recent updates
NTL 600k Broadband

  BigMoFoT 11:18 20 May 2003

I had same problem and my drive is now in the Sony repair centre! The only thing I'd advise is updating the firmware on the drive if this has not already been done.

  BigMoFoT 11:27 20 May 2003

Oops, didn't read that bit - it shouldn't be in PIO mode - this is why its burning slow as there settings do not allow fast data transfer between mobo/and IDE device - if you can't change in back to DMA then you have a problem..DMA settings can be set in the BIOS but Windows may over ride these settings so you may have to reinstall windows

  BigMoFoT 11:30 20 May 2003

It is possible if you have already flashed it that is - that you didn't disable any packet writing software (DLA, InCD, DirectCD) and may have caused damage to the drive

  Telyob 11:33 20 May 2003

The original speed that I had means that DMA must have been working to start with, I wonder if there is a setting in the registry that I can change to allow it to change back?

BTW how did you get Sony to agree to repair yours?

I ran their drive check utility and it reported everything as OK! But it does not check speed, only the fact that it can read and write.


  Telyob 11:40 20 May 2003

Oops, missed your 3rd reply.

I flashed it with 2.0e as soon as I installed the drive, before I even wrote a disc, and it worked fine.

It must be something that happened later than that.

  BigMoFoT 11:43 20 May 2003

I also ran the drive check and that was OK! In terms of repair I have a thread in the consumerwatch which you might find interesting. Do a search for the sony drive in that forum!

  Telyob 12:10 20 May 2003


Sorry, but your thread in the consumerwatch forum seems to be missing, did a search on Sony or DVD and nothing there about it.

  crx1600 12:18 20 May 2003

goto the Sony site and run the diagnostic tool click here

1x DVD is about equal to 8x CD and as such a full DVD does take about 1 hour to record.

"A 2x recorder, running at 22 Mbps, can write a full 4.7G DVD in about 30 minutes. A 4x recorder can do it in about 15 minutes." click here

  crx1600 12:30 20 May 2003

also it looks there are problems with certain nero upgrades click here

is it possible the problem started after doing a nero upgrade?

  Telyob 13:13 20 May 2003

Writing a file that took 40 mins before now takes about 75 mins even with 4x DVD-Rs.

It's possible that a Nero update happened at about the time, but I went back to the previous version and the problem was still there.

I am sure that it is the DMA / PIO problem but how can I make the drive work in DMA mode?

New BIOS, Chipset Drivers and drive firmware don't seem to help.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HP Envy x2 review: Hands-on

Iconic New York graphic designer Milton Glaser on his uplifting new subway posters

New iMac Pro release date, UK price & specs rumours

Comment suivre le parcours du père Noël ?