Small External WD Hard Drive USB Power behaving badly.

  nerawan2 17:55 12 Dec 2013

Hi. I have a small hard drive (WD)power only by USB. It belongs to a friend. It was behaving weird in his PC so I took it to mine but it's the same problems. It was formatted in FAT 32 and I thought that was the cause. I re-formatted it in NTFS and the problem is still the same. There are files(videos0 with a 2 Gb size in average. I transfer some of them to my PC so I could format it. I was able to transfer some and have to del;ete the others. Now I'm transfering back the files to the external hard drive and it sa very PICKY. Just copies some of them and refuses to copies others. Also sometimes the PC refuses to accept this hard drive and I have to switch it off and then On again. Most times I get a message "it has to be scan for problems". I do it and then it says"there are not any problems". Any idea what is happening and how to correct this problem. Thanks.

  Fruit Bat /\0/\ 18:55 12 Dec 2013

I suggest you try a Low level format of the drive possibly do it to or three times to deep clean the drive.

  Bris 15:13 13 Dec 2013

The scan for problems message is probably because the OS has noticed a drive is connected to a USB port and that drive has be disconnected which can result in corruption hence it suggests a scan but of course finds nothing as no data transfer has taken place.

These drives draw a lot of power from a USB port which has a limited 500ma available and often run at near maximum. The problem may be down to power fluctuations.

Suggest you try a good quality cable the shorter the better.

  nerawan2 17:16 13 Dec 2013

Last night I tried the program Bait suggested. it's slow and started at midnight. After 1 hour it had formatted less than 10% so I left it overnight. At 9 a.m. I checked and it had stopped at £:30 a.m. and did only 30 %. Now it looks the problem is worse. Disk magnement sometimes recognize it and says HEAlTHY. but if I tried to formatted later I get message"the format was completed" and MY PC aknowledge a hard drive but refuses to open it. Any suggestions?

  nerawan2 17:17 13 Dec 2013

sorry the message is "The format was not completed".

  Fruit Bat /\0/\ 17:57 13 Dec 2013

Sounds like the drive is really struggling to survive

however as you have nothing to loose

open up the drive casing and you will find a perfectly normal 2.5 inch sata drive in there, connect it to one of the free sata ports on your mother board and retry to format the drive.

  nerawan2 18:49 13 Dec 2013

I don't really know how to do that.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 6 review

Procreate's iPhone app offers new brushes, a larger canvas and better support for the iPhone 8/X

Best multi-room speakers for iPhone & Mac owners

Streaming : comment regarder le lancement de Xiaomi en France ?