Slave drive recognised by BIOS but not My Computer

  reworp 08:27 15 Feb 2004

My second (slave) hard drive used to work fine but after upgrading my main (master) drive, and then re-starting, Windows XP does not recognise it.

The slave is recognised by the BIOS and showing as okay. It is also showing as recognised by Device Manager (and shown as working properly) but I cannot see it anywhere in My Computer, even in the "Disk Management" section of utilities.

  DieSse 08:39 15 Feb 2004

Try "Add new hardware" in the Control panel - I've seen it make drives pop into view.

  reworp 08:49 15 Feb 2004

Thanks. Had already tried it and run it again, still no luck. It recognises that there is already a driver installed and says all is okay, but still can't see it.

  georgemac 08:49 15 Feb 2004

I suspect it is because the aprtition table will still have the old drive as c:

I just fitted a new drive and had the same, OK in bios but windows could not see it as it had no partition table.

I used partition magic to fix, but if you click start, help and insert "drive change" and search, then click on assign change or remove a drive letter, it will show you how to open the computer management console and hopefully you can change the drive letter of the 2nd drive and it will be OK.

  reworp 08:51 15 Feb 2004

Thanks. Will have to try that later as need to get new version of Partition Magic.

  georgemac 08:52 15 Feb 2004

To open Computer Management, click Start, and then click Control Panel. Click Performance and Maintenance, click Administrative Tools, and then double-click Computer Management

  georgemac 08:55 15 Feb 2004

when you open the Computer management console, clickk on computer management local then in RH window dbl click on storage then dbl click on disk management local the right click on 2nd drive and select change drive letter or paths - hopefully this will work.

  reworp 09:21 15 Feb 2004


Many thanks, but have been using Computer Management and it doesn't recognise the sencond drive. I use "Computer Management" quite a lot so am familiar with it, and use it to partition and allocate drive letters, but for no obvious reason Windows simply can't 'see' the drive any more even though it is listed in Device Manager.

  georgemac 09:58 15 Feb 2004

click here what type of drive is it - suggest looking at the drive makers website and downloading their disc tools utility for installing hard drives and trying this?

  reworp 10:05 15 Feb 2004

Thanks to all for the help.

Even though there is no letter assigned, I've now got the drive recognised by "Drive Image 7" which is letting me copy the drive to a separate partition. At least that means I haven't lost any data, but will try your advice in order to get the drive properly allocated.

Many thanks.

  OU812 18:40 15 Feb 2004

Try the following:

Go into device manager.
Click on IDE ATA Controllers.
Check under the advanced tab that your slave drive on IDE1 is set to auto-detect and enable if not.

You will now be able to view your slave drive in Windows.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

3D illustrator Billelis on how to promote yourself on social media

iMac Pro review

Apple Music : comment obtenir 3 mois gratuits ?