Sitecom 54G Wireless router

  metaphor 11:59 09 Nov 2008

Hi all.

I'm having a very hard time trying to configure my new wireless router sitecom 54G...

As some other people, I too can get a connection (both wired and wireless) but no internet access.

I think the problem is the fact that it's not being able to obtain a dynamic ip address. I've tried all I can remember - ipconfig/release and renew, several resets, several wizard configurations, and none solved the problem.

The problem is not in the pc because both my desktop and my laptop are having the same problem...

This is my status screen here: click here

When I click in "Renew" I get a message saying "Get dynamic IP renew fail!".

I'm running out of options and would be very grateful for any help whatsoever.

Best regards.

  Ashrich 14:05 09 Nov 2008

How did you set the router up ? With an ISP's CD or manually , and what is the router status when you access the WAN page . Are you using a separate modem and wireless router or an ADLS modem/router ?


  metaphor 14:21 09 Nov 2008

The router has a setup wizard which allows you to select the country and isp you're on (i'm in Spain currently - Telefonica isp).

When I click on it it asks me to fill the PPPoE user and password (which I did). This was unsuccessful though.

I also tried to configure settings manually and I had these options: Static IP address; Dynamic ip address; PPP over internet; PPTP.
Tried dynamic ip address and PPP over internet with no success.

This is what shows up in the router status: System

Uptime: 0day:2h:35m:17s
Firmware: v1.0
Wireless Configuration
Mode: AP
Band: 2.4 GHz (B+G)
SSID: Sitecom47905A
Channel Number: 11
Encryption: Disabled
BSSID: 00:0c:f6:47:90:5a
Associated Clients: 0
TCP/IP Configuration
Attain IP Protocol: Fixed IP
IP address:
Subnet Mask:
Default Gateway:
DHCP Server: Enabled
MAC address: 00:0c:f6:47:90:5a
WAN Configuration
Attain IP Protocol: Getting IP from DHCP server...
IP address:
Subnet Mask:
Default Gateway:
MAC address: 00:0c:f6:47:90:5b

The router is separate from the modem.

Also this is what shows up when I run IPCONFIG/ALL:

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

Windows IP Configuration

Host Name: metaphor
Primary Dns Suffix :
Node Type : Unknown
IP Routing Enabled : No
WINS Proxy Enabled : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description : VIA Compatable Fast Ethernet Adapter

Physical Address : 00-19-66-19-46-DE
Dhcp Enabled. . : Yes
Autoconfiguration Enabled : Yes
IP Address. . . :
Subnet Mask . . :
Default Gateway :
DHCP Server . . :
DNS Servers . :
Lease Obtained: domingo, 9 de Novembro de 2008 15:12
Lease Expires . . . . . . . . . . : quarta-feira, 19 de Novembro de 2008

Thanks for your help.

  Ashrich 23:32 09 Nov 2008

Is the modem actually connected to the Internet ( is this what you are using to contact this forum ) if so then you shouldn't have to enter the user name and password again on the router as they have already been done on the modem ( or are you trying to replace the modem with a modem/router ? )

It sounds like , and I am sorry if I have got things wrong , that you are connecting a modem/router to a modem , which can't really be done , the set up wizard should detect the modem and the internet and just get you to set up some kind of wireless encryption .

Can we have the exact make and model number of the Sitecom box please . Do you know the IP address of the modem ?


  Ashrich 23:36 09 Nov 2008

This isn't Telefonica Cable by any chance is it ?


  metaphor 17:26 10 Nov 2008


No this is a Telefonica modem and I'm trying to configure a sitecom router.

The exact model is Sitecom 54G router WL-600.

I'm talking directly through the modem, which works fine, and this is Telefonica ADSL connection.

Thanks for the help

  Ashrich 18:53 10 Nov 2008

Assuming you have the ethernet cable from the modem into the WAN port of the router , what happens if you choose DHCP instead of PPPoE in the direct set up pages of the router ?

  metaphor 19:06 10 Nov 2008

I don't have that option...The only options are static ip address; dynamic ip address; pppoe and ppptp (or something similar).

The router just doesn't seem to be obtaining the wan ip least that's what I can take from this status:

WAN Configuration

Attain IP Protocol: Getting IP from DHCP server...
IP address:
Subnet Mask:
Default Gateway:
MAC address: 00:19:66:19:46:de

  Ashrich 00:48 11 Nov 2008

Just a quick question , what PPPoE user name and password did you enter ? Was it the user [email protected] and adslppp for the password


  metaphor 17:35 11 Nov 2008

yep...and with no success

  mgmcc 20:45 11 Nov 2008

Try "Dynamic IP address" so that the router gets its WAN IP address by DHCP from the Modem.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review: Hands-on

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?