sis7001 usb HELP!!!

  Drax of Terigon 15:58 07 Mar 2005

please help me. i have built my pc from scratch but this is where my limit is. i have ordered bb with bt and have discovered that my usb ports are not working! these are the tech details:

system information>components>USB>
SiS 7001 PCI to USB Open Host Controller PCI\VEN_1039&DEV_7001&SUBSYS_70011039&REV_07\2&EBB567F&0&0A
SiS 7001 PCI to USB Open Host Controller PCI\VEN_1039&DEV_7001&SUBSYS_70001039&REV_07\2&EBB567F&0&0B
USB Root Hub USB\ROOT_HUB\3&32875407&0
USB Root Hub USB\ROOT_HUB\3&173F0BD1&0

in device manager they are working fine

motherboard is
M810LR by Hsing Tech Enterprise Co ltd

chipset is

platform is
windows xp prof no sp1 or sp2

BIOS Amibios ID string is

please can anyone help me out. i stand not having no usb ports. i have so many things i want to do but cant.


  Yoda Knight 16:07 07 Mar 2005

check that they are enabled in your bios and dont double post

  Drax of Terigon 16:14 07 Mar 2005

they are enabled in the bios. there are two options. the other for dos mode. tried both ways i'm afraid this aint gonna be easy to solve as i have tried everything except flashing my bios but i dont want to do that unless there isnt any other option. and i want to make sure i know exactly what i am doing when it comes to the bios as i hear it is irreversible :o

  Fruit Bat /\0/\ 17:16 07 Mar 2005

You need Sp2 for USB2 drivers.

  Drax of Terigon 17:47 07 Mar 2005

but my usb isnt 2.0 or it would say enhanced USB open host controller in device manager. i think mine is either 1.0 or 1.1
the usb ports are connected to mobo , not to usb pci card.
does anyone have same sis730 , m819lr problems or am i the only one? that way i know its my mobo thats buggered :(
fruit i did dl usb 2 from driverguide but it only made my pc freeze which tells me theyre wrong driver.
also it were as simple as that then win9x, 98 2nd, and ME would of worked which i had all installed. didnt really make a difference.

the only time i had anything near to working properly is when i plugged in a 64mb memory stick. xp home edition's taskbar reported unknown device but i couldnt find a driver for the stick.

ugh, i feel depressed :(

  Drax of Terigon 17:49 07 Mar 2005

oh and can a moderator please remove my second posting. sorry it was a accident.

  Fruit Bat /\0/\ 18:38 07 Mar 2005

click here

ADSL modem USB adapter 2.5

  Drax of Terigon 16:07 14 Mar 2005

nah, no good i'm afraid. its for win98. sorry to be a pain but i think i'll thro this pc out of my 4th storey window.

*wooosh. patooofff. smash. RIP + Duron 800 >:~D
muhahaharharhaahaaaaahaaa he

  sgoku 17:23 14 Mar 2005

Some motherboards in my experiance like you to have sp1 installed before they will work

  Fruit Bat /\0/\ 18:31 14 Mar 2005

You need SP1 or SP2 for USB to work properly in XP

SP2 contains all the SP1 drivers so better to install SP2.

  Fruit Bat /\0/\ 18:37 14 Mar 2005

E-mail me using the yellow envelope and I will send you the SIS7001 PCI to USB Open Host Controller inf file.

Also try and download the VIA 4 in 1 drivers from click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

See iconic duo Smith and Foulkes' epic animation for the BBC's Winter Olympics coverage

iMac Pro review

Idées cadeaux pour geeks et tech addicts