SiS Control Center has stopped working - Vista Laptop

  Graphicool1 13:20 22 Jun 2012

After my problems with it not connecting to the Internet without an Ethernet cable. I eventually did a System Restore back some 3 weeks, when it could connect wirelessly. So that now seems to be working, however another problem has presented itself...

'SiS Control Center has stopped working'

  northumbria61 13:26 22 Jun 2012

Try running the Registry option in CCleaner Scan for Issues

  Graphicool1 13:36 22 Jun 2012


That was the first thing I did, it didn't make any difference though. I also ran CHKDSK. That didn't do anything either

  northumbria61 13:43 22 Jun 2012

Take a look here enter link description here

  northumbria61 13:44 22 Jun 2012

It could also be a driver issue - have you tried updating your Network Adapter via Device Manager - if it doesn't work you can always roll back.

  Graphicool1 14:17 22 Jun 2012


I followed your link, but I can't see what that or updating the Network Adapter, has to do with my problem? Being as my original problem is all behind me now. That was my being unable to connect to the Net without a cable, as now I can connect with and without a cable? So why would I want to update something that is working OK.

From other searches I've done on the Net, when talking about the 'SiS Control Center', they talk about updating the VGA driver, but I'm uncertain how to go about this?

  northumbria61 14:32 22 Jun 2012

Sorry I misunderstood. To update your VGA driver go via Device Manager - Start -Search Box - type Device Manager - Display Adapters - expand and right click - select Update Driver Software - select Search Automatically for Updated driver Software.

  Graphicool1 15:32 22 Jun 2012


I tried that and as ever it couldn't findanything and I was unable to do a roll back, because the button is greyed out. I have since been given a link to a site where I am in the process of installing the chipset driver, which contains all the drivers I need?

I've just set a System Restore Point to be on the safe side, so toes crossed, I'm going in.

  Graphicool1 16:04 22 Jun 2012

Been there done that and everything seems the way it should be. Except for one, (hopefully) small issue, before this whole episode, the 'Display Adapter' was called...'SiS Mirage 3 Graphics (Display Adapter)'. However, now it's called...'Standard VGA Graphics Adapter'?

  northumbria61 16:14 22 Jun 2012

The name can be changed but hardly worth it - see here enter link description here

The LINK relates to changing a Wireless Card/Network Adapter but it is the same.

  northumbria61 16:21 22 Jun 2012

Explanation as to why reverted to Standard VGA Graphics Adapter enter link description here

You could try updating the driver again but this time choose from the options - Browse My Computer for Driver Software instead of Search Automatically for Updated Driver Software.

This should revert it back to how it was.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review: Hands-on

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?