Sims 2 Missing .DLL file

  Jim H 10:31 28 Dec 2004
Locked

Morning all,

Hope you all had a great Christmas. I installed my daughters new Sims 2 game and after installation, when I try to run the game the following message appears;
"A required .DLL file, D3D9.DLL, was not found"

I have uninstalled the game and reinstalled but the same message appears. Windows Me, 1.5ghz, P4, Nvidea graphics, creative sound card.

Thanks for any help

James

  VoG II 10:38 28 Dec 2004
  Jim H 10:53 28 Dec 2004

Hi VoG

Thanks for the help. I downloaded the file and transferred to CD to install on my daughters computer. Installed by winzip, it recognised the sims directory for the transfer but when I tried to restart the game the same error appeared.

  VoG II 10:58 28 Dec 2004

Try putting it in c:\windows\system

  ACOLYTE 11:01 28 Dec 2004

You may be better re installing directx this file should be installed with that.

  Jim H 11:09 28 Dec 2004

VoG, did what you said and when I now try to start the game I have a new error message;
"The D3D9.DLL file is linked to missing DDRAW.DLL:DdEntry21"

ACOLYTE, I tried to install directx9 which camewith the game and had the following error message;
"A cabinet file necessary for installation cannot be trusted"

  ACOLYTE 11:35 28 Dec 2004

Sounds like a corrupt/incomplete Directx9 instalation,you could try dloading it from microsoft click here

  ACOLYTE 11:39 28 Dec 2004

click here


Sounds like this is a regular error with the sims.

  Jim H 12:30 28 Dec 2004

ACOLYTE

Downloaded Direct X 9c but still has the same error message when I try to install!

Any way round this?

Thanks

James

  ACOLYTE 12:45 28 Dec 2004

Try start run and type dxdiag in the run box
then check the files for direct x are all ok then
goto the display tab and make sure that direct draw and direct 3d are enabled and run the tests
to see if it passes.

  Jim H 13:01 28 Dec 2004

ACOLYTE

direct draw - passed all tests
Direct 3d
- 7 test results - Failure at step 8 (creating 3D device) HRESULT - Ox8000405 (generic failure)
- 8 test results - Failure at step 8 (creating 3D device) HRESULT - Ox8876086c (error code)
- 9 test results - Failure at step 8 (creating 3D device) HRESULT - Ox8876086c (error code)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

Inside the iMac Pro - Apple's most powerful Mac yet

iMac Pro release date, UK price & specs

Comment nettoyer Windows et optimiser son PC gratuitement ?