Sharing a printer with Accounts in Win XP Home

  Keith35 15:11 12 Jan 2004
Locked

Hi, anyone got this trouble?
I have two accounts set up. Me as Administrator, my son as Limited. Running Win XP Home, all installed peripherals work in both accounts. Just installed, and that was it. With my printer (Epson 680), went through install procedure. Works on my account, not in my son's, even though I get the Printer Ready sign and the spooler loads the file to the printer. Then, nothing!! Tried reinstalling, same thing. The Advanced Tab in Properties in my son's account is "greyed" out.
Any ideas. Epson couldn't help and the MS site had no answers!
Keith

  alcudia 15:16 12 Jan 2004

Could be connected with permissions. Try changing your son temporarily to an administrator and see if it works then.

  Keith35 15:34 12 Jan 2004

Hi Alcuida,
thanks for the response. Unfortunately, it didn't work. This was one of the solutions advised by Epson. Under XP Home, I thought the permissions for peripherals were a done deal for all users! Also tried a total cleanout of everything Epson, then another re-install. Same stuff. It's not a terrible problem, just annoying. I can print my son's stuff by sending the docs to my own Docs File, but it shouldn't be that way!!
Keith

  stuc100 15:38 12 Jan 2004

Have you given you son access to the printer through your admin acount?
Try accessing the properties of your printer in your account then look under security or sharing.

  alcudia 15:42 12 Jan 2004

Sorry, you are right. I'd missed that you are using Home. I'll keep thinking.

  Keith35 16:04 12 Jan 2004

Hi, thanks for your response."Security" is not an option in Properties, so I guess this is another Win XP Pro thing. As to "sharing" this appears to be a set-up to allow sharing across a home/remote network. Is there some way of relating it to my son's account? Sorry to be an old bore, but at 70 I guess I must be a bit dim!
Keith

  alcudia 16:14 12 Jan 2004

Quite right. Neither should apply in your case. However if your restart in Safe Mode you should have a Security Tab in the Properties dialog. Won't hurt to try, but printers should be available for all users in Home.

Sharing, as you say, is for networked printers.

A bit more head scratching needed I'm afraid.

  alcudia 16:19 12 Jan 2004

When you installed the printer did you also try installing it when logged in as your son.

I assume it shows in the printers folder and does not display any errors. If it does try removing it and reinstalling when still logged in as your son. A wild shot, but you never know.

I only have experience of XP Pro and networked printers, but each printer has to be installed for each user individually with this setup.

  Keith35 17:05 12 Jan 2004

Thanks for taking the time to help.
I will try both suggestions, starting in reverse order! I have a feeling that I can't install anything whilst my son's account is Limited, but I can try. If that fails I will change his status to Administrator. If that fails I'll try your Safe-Mode suggestion.
I'll report back tomorrow, because just to make it a set, my automatic garage closing device has failed so I'll sort that out first!!
regards,
Keith

  Keith35 17:33 12 Jan 2004

Done it! Thanks a lot. Changed my son's account to Administrator, then back in my account went to Control Panel, Printer, clicked on properties, chose Sharing, chose Share this Printer, OK.
Logged back into my son's account, and hey presto the printer worked fine.
Changed his account back to Limited, still works fine!
Don't know if that makes sense, but it works.

Thanks again
Keith

  alcudia 21:30 12 Jan 2004

A bit unusual, but if it works who cares. Glad it's sorted.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

Turn a photo into 16-bit pixel art

iMac Pro release date, UK price & specs

Comment suivre le parcours du père Noël ?