sfc /scannow problem

  hugh-265156 11:05 20 Sep 2003

hi all,i have xp home which came pre installed on a packard bell pc.recovery is via floppy disc which used to read from a hidden partition.this also ment that sfc ran without inserting a windows cd.

shortly after getting my computer last year i used packard bells master cd creator to make my own master discs,this process freed up the space taken up by the hidden partition and then deleted it.as it turned out the cds i created were corrupt but packard bell very kindly sent me three new master discs which work fine in conjunction with the floppy.

xp has been reinstalled four or five times now in this past year or so via the recovery floppy and master discs.the hard drive has also been completely reformatted via fdisk many times,linux installed etc and so no longer has the hidden partition,even still when i ran sfc after this it has never asked me to insert a windows disc.with me so far? ok heres my problem:

im just after running sfc and it gets about quarter of the way through the process and says:

"files that are required for windows to run properly must be copied to the DLL cache please insert your windows xp home edition cdrom now"

if i click cancel it throws up the message again.i tried inserting all three master discs which i have stated above that i have never had to do before and it rightly says that they are not a valid windows disc.

last time i ran sfc was about 3-4 weeks ago(usually run it once a month) and all was fine.unfortunatly i dont have restore points that go back that far.sorry for the waffle.thank you.

  AndySD 11:10 20 Sep 2003

Try pointing it to the i386 folder on the disks or you can see if it will accept the i386 on the hard drive.

  hugh-265156 11:19 20 Sep 2003

thanks AndySD.unfortunatly i only have retry,cancel and more info tabs,no browse to folder tab option.

when i click the more info tab it says the disc i have inserted is not a valid windows disc or my version of windows is different from xp home.

  Djohn 11:27 20 Sep 2003

As you have the Product key to your install of XP Home and it is a legal version provided by Packard-Bell, Just seems that a file is missing or corrupt. Would it not be in order to borrow a copy of XP Home CD and transfer the files to your Hard Drive, or even a CD for future use? Regards. j

  hugh-265156 11:35 20 Sep 2003

thanks ßéŁâ and Djohn,i will try the registry first and see what happens.seems strange that its only asking for a windows cd now after all this time?.my i386 folder is located in C:/windows/service pack files/i386 still.

  AndySD 11:39 20 Sep 2003

It should also be on one of the CD's

  hugh-265156 11:56 20 Sep 2003

ok i have tried pointing the SourcePath to my i386 folder on the hard drive(triple checked it was correct),restarted the computer and ran sfc and it still prompts me to insert a disc.i checked all three master discs via search and had a look on them myself,no i386 folder to be found.

  hugh-265156 19:14 20 Sep 2003


  MichelleC 09:53 21 Sep 2003

May be worth contacting M$ as their support is pretty good. This link shows all available commands which may help some: click here

  hugh-265156 10:18 21 Sep 2003

thanks MichelleC,link going into my favorites.

  hugh-265156 16:01 30 Sep 2003

any more ideas guys n gals?

i am all googled out.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Wacom Cintiq Pro 24 and 32 review – hands-on

When is the next Apple event?

Gmail : comment annuler l’envoi d’un e-mail ?