Hot Topics

SFC /SCANNOW not functional

  johndrew 18:27 18 Dec 2011

I have had some problems withh XP of late and attempted to run sfc /scannow to check the files. It appeared to start fine and asked for the CD which I inserted but continued to not recognise it even though the CD booted to the installation window - I cancelled this.

I did some reading on the subject and checked the setup with regedit it was set to look in C:. There is a copy of I386 in C:\ as well. I am the only user with full Administrators rights but can find no reason for sfc /scannow not to run - it has recently.

Can anyone suggest a course of action that should get me back on track?

With thanks in anticipation.

  rawprawn 18:50 18 Dec 2011
  Fruit Bat /\0/\ 18:53 18 Dec 2011

The problem is usually down to servicepack sourcepath after installing updates

so using your lihk make sure they are set correctly

  T0SH 15:59 19 Dec 2011

The problem that leads to sfc /scannow being unable to locate the Windows CD, is often caused by the optical drive letter having changed from D to E or some other letter since an install or even a repair install was done (the DIR this location of the Windows CD is stored in the registry)

It is fairly easy to correct by moving the drive letters after (the root drive "C" which is fixed) around to get the optical drive back to as was

Cheers HC

  sunnystaines 16:40 19 Dec 2011

try chkdsk too

  johndrew 12:28 20 Dec 2011

Hello all. Many thanks for your replies and my apologies for not getting back before, but the whole PC has had to have a complete ATI recovery (I'm glad it was only a few days since I did a full backup) as it went down completely.

I haven't tried either sfc /scannow or chkdsk since recovering the system but in answer to your comments:

buteman/rawprawn/Fruit Bat /\0/\/T0SH/sunnystaines

I had run sfc /scannow a few hours before and it worked perfectly without a CD as I have set regedit (as in my link) to look at the I386 file in C:. Regardless of this being set (I did check to make certain it was correct) it asked for the CD. Nothing I could do or find recovered from this. I should add that I have always used the same optical drive - which still has the same ident - for the Windows CD.

Between running sfc /scannow for the first and the failed attempt, I had run Advance System Care V.3 which advised of a problem and recommended running chkdsk; I did this and nothing was found. It was after these two operations that I attempted to run sfc /scannow and it failed. Subsequently the whole system went down for no apparent reason.

I find the whole saga rather strange as, other than toolbar problems mentioned a while back and freezing programs which took on a life of its own, things have been functioning reasonably well.

Any comments?

  johndrew 15:58 20 Dec 2011

Well, I have just run sfc /scannow to check it was functioning and it worked as it always used to - no CD reading from C:I386. I watched Task Manager whilst it was running and other than AVG 'checking' there appeared to be no other activity.

I have just re-read the comments above and note that by buteman where he says, "If you have SP3 downloaded you need to add that to your windows xp disc ..". I am running XP Pro SP3, but have never used anything other than the I386 file from the SP2 CD. The comment raises two questions in my mind:

  1. Does SP3 change the Protected Files in XP?
  2. If so, does it also mean that other software may be affected?

Can anyone confirm any of the above?

  Fruit Bat /\0/\ 19:45 20 Dec 2011
  1. yes

  2. No

  3. There is a registry entry servicepack sourcepath (see my first post) SFC looks at this and as well as using files in C:i386 will also use the new files from the service pack update.

  johndrew 10:33 21 Dec 2011

*Fruit Bat /\0/*


Now I understand fully what you were saying. My initial understanding was flawed!!

I guess the path/link was broken and that caused my problem - I doubt I would have been able to trace it anyway!!

Thanks for the clarification.

This thread is now locked and can not be replied to.

1x1 pixel
Elsewhere on IDG sites

Trump issues executive orders to restrict TikTok and WeChat in the US

Yuke Li's 'pencil' drawings are entirely digital

Different Think: Microsoft is out-designing Apple

Les meilleurs bracelets connect├ęs (2020)