sfc /scannow

  swapper 07:42 14 Nov 2004
Locked

Win XP HE.
I am having a problem with sfc /scannow.
I have two unconnected PC's so can check one with the other.
I have downloaded instructions from click here but cannot resolve the problem.

scannow will not pick up the 1386 file that I have loaded into C drive, desptite double and double checking that I have amended the registry correctly, I keep getting told to load the correct disc.

the other PC is running fine.

Any help please?

  rawprawn 07:58 14 Nov 2004

Sorry, I don't understand your question, and your link isn't working. If you run SFC you need your XP disc to correct any faulty files, is that what you are trying to do?

  BurrWalnut 08:44 14 Nov 2004

Apart from anything else the file should be called i386, i.e. eye386 not one386.

  Stuartli 09:45 14 Nov 2004

You have to be the Administrator to be able to use SFC in XP.

Information on the commands can be found in Help and Support under SFC from the search box.

  swapper 13:12 14 Nov 2004

rawprawn, BurrWalnut and Stuartli, sorrrry, the link should be click here

I am the Administrator.

I have my original XP disc, but the system will not accept it, I keep being told to insert the correct disc.

Because of this I have used the advice from the above excellent site and installed I386 (not 1386) to C:\ drive, and amended the registry files as advised by this site(click here).

I know this advice is good because I have done the same adjustments on my other PC.

After doing this, when I use sfc /scannow, it should use the I386 file on C:\ drive, rather than need the original disc, but it will not pick up from C:\ drive, and still asks for the disc.

TIA

  User-312386 13:19 14 Nov 2004

Did you change the source path to C:\ ?


HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\SourcePath

  User-312386 13:30 14 Nov 2004

I just copies all my I386 files from my XP disc and tried it

It works perfectly

  Stuartli 13:50 14 Nov 2004

Or browse to the correct folder/file?

I have a copy of XP Pro and SP2 on a separate partition on my hard disk, along with some other backup files.

  swapper 13:54 14 Nov 2004

yes, I have tried this several times, and yes I have amended the registry, I am a bit confused as to why I cannot use scannow in any way without being asked for the disck that I have?

  BurrWalnut 14:17 14 Nov 2004

You probably haven't changed enough registry keys.

A mininum of 4 registry entries (SourcePath and ServicePackSourcePath) contain pointers to where the files are. They are either in a hard drive folder (i386), on an optical drive or possibly both. Problems can arise when drive letters have been changed after the initial install, e.g. adding a new drive or implementing a dual-boot system will not update the registry pointers to the i386 folder.

  swapper 07:00 15 Nov 2004

Well BurrWalnut, I have followed the advice in click here information I am sure, but I don't know where else I can check, could you enlarge on your have your "You probably haven't changed enough registry keys" suggestion please?

TIA

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HP Envy x2 review: Hands-on

Iconic New York graphic designer Milton Glaser on his uplifting new subway posters

New iMac Pro release date, UK price & specs rumours

Comment suivre le parcours du père Noël ?