sending to printer but not printing

  rubygxx 08:36 19 Jun 2012

Hi, trying to help a friend, his printer was working fine then the other day he received an email, printed it , but now when he tries to print anything it goes in the printing queue but the printer stays silent, nothing prints, i run the troubleshooter , printed a test page , which printed fine, so i cannot work out why it wont print, everything i have checked says printer is ok , working correctly, i changed the settings for the printer to print directly to the printer , and then i managed to get a page to print, thought i had fixed it, but then when we went to print again the page we were printing froze, says not responding, , no matter where i tried to print from got the same , i took the laptop home, connected it to my printer and printed perfectly, checked my settings and they are the same as his were before i changed them, so i am going to change them back, but that takes me back to the problem of the printing going in to the queue but not printing !it is an HP deskjet 1050 J410, windows 7, any suggestions much appreciated

  spuds 10:06 19 Jun 2012

Have you tried re-installing the drivers, or latest driver updates?.

  rubygxx 10:30 19 Jun 2012

Yes thank you, that was first thing i did, the flag at the bottom of the screen was saying the printer was missing a driver , i uninstalled and reinstalled the drivers , but it still would not print, i do not understand how it would print a test page though and not anything else . the printer has the green tick saying its ready,i went online to HP site and did a scan thing which tested the printer , everything was ok according to that, still wont print !

  northumbria61 10:36 19 Jun 2012

Unplug the mains cable and the USB cable - then re-connect the mains cable and USB cable in that order.

  spuds 11:02 19 Jun 2012

Follow the above instructions, but wait a minute or more before reconnecting, so as to perhaps clear memory!.

  rubygxx 20:42 22 Jun 2012

sorry i haven't got back about this, i have been working and have his laptop in my house, not had time to go to his yet, will do soon and let you know what happens, thanks

  robin_x 20:47 22 Jun 2012

Also consider restarting the Print Spooler service.

Even if it says it is already running.

(Start Run services.msc)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Social Media has Propelled Political Graphic Design and Art in the Last Decade

The best kids apps for iPhone & iPad 2018

HomePod d’Apple : date de sortie, prix et fiche technique