Security center will not run

  birdface 08:48 14 Nov 2011

While having problems installing Avast yesterday I noticed That My Security Center would not run.

I am using W/7 32bit.

I have ran my Security programs.Tried a system repair in safe mode.Tried to get it to run in Services and have run sfc /scannow without any luck.

After Googling it it does seem to be a hard one to fix.So just wondered if any of you have had the same problem and managed to fix it.

I did remove MSE yesterday using Revo Uninstaller but not sure if the problem was already there or not.

I had to install Avast in safe mode to get it to work properly as I could not get it to work in normal mode.Tried twice.

Question is do I really need the Security center running or can I do without it.

Still getting my Windows Updates so no problem there.

  gengiscant 09:04 14 Nov 2011

Go to start, search type CMD then right click on command prompt select "run as administrator" at the prompt type:-

net start Winmgmt press enter, then:-

net start RpcSs press enter, then:-

net start DcomLaunch press enter, then:-

net start wscsvc press enter.

You should receive a message about the service started OR already started , just move on to the next command.

Or there's this: MSE

  onthelimit1 09:08 14 Nov 2011

For interest, why did you decide to change from MSE to Avast?

  birdface 09:29 14 Nov 2011

Sorry not got time to answer just now have a doctors appointment,Will get back to you as soon as possible.Thanks

  birdface 12:53 14 Nov 2011


No difference it still states A System error has occurred.System error 5 has occurred access is denied.That is what it said in services so no joy there.

Will have a look at the MSE post in a moment.


MSE was all right as an anti-virus the spyware part of it slows computers down and anyone with an oldish computer would struggle with it.

I gave my son a loan of the computer and put it on there for him as it was the simplest to use.

Now I have it back I wanted something better and have the full version of Avast until April.

  birdface 13:22 14 Nov 2011

gengiscant on your 2nd link.

  1. Open the Local Users and Groups manager.

Any idea as to where you find it.Is it supposed to be in user accounts.

Not on my version of W/7

Already tried the first version by setting it to automatic brought no results so had to press run to get the same information as before.System error 5.

  gengiscant 13:32 14 Nov 2011

Local Users and Groups is only available in the Windows 7 Professional, Ultimate, and Enterpise editions. I am assuming you do not have any of these?

  birdface 13:39 14 Nov 2011


No I have Home premium no wonder I could not find it.Felt a bit of a clown having to ask.

I have been reading some of the other threads with the same sort of bother and there are a lot of folk out there that know what they are doing.I am afraid I am not one of them

Using a new user account was mentioned so might leave that as a last resort.

  gengiscant 14:54 14 Nov 2011

This problem you are having may well be caused by left over files from MSE. Sometime ago I had a lot of bother getting rid of it and installing some other anti-virus. Since upgrading to Windows 7 I have been using MSE without any problems and only scan when nagged to do so.

A bit of reading here but nothing definitive: Security center.

  Les28 14:58 14 Nov 2011

A few ideas that may or may not help, maybe check in services.msc that Revo has uninstalled the Microsoft Antimalware Service (MsMpSvc) component of MSE and that it's not still running as an orphaned service and perhaps causing the WSC and Avast install problems.

Any errors showing in Event Viewer that could be connected?

Also perhaps a repair of the WBEM \ Repository folder might be worth considering, you can Google to find out if you think it may be worth a try.

  birdface 16:18 14 Nov 2011


No nothing on there that helped.

Tried the Zip file but that was no good.


(MsMpSvc)is not running in Services and WBEM \ Repository folder should only be changed by those that knows what they are doing,So that leaves me out.

I would like to get it fixed but computer is working ok without it, No doubt that there will come a time when it is needed.

Thank you both for your help so far.I will keep on looking but I think it may be a lost cause.

Can you do a system restore to a previous time and then restore back to the present time just to see if I could find out when it was working ok.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Artist Helen Friel on designing paper models for everyone to make

What to expect at Apple's 27 March education event

Idées cadeaux pour geeks et tech addicts