Searchfilterhost.exe hogging 50% of my PC

  pdk 11:59 04 Dec 2008

I have finally found out what is slowing my PC and I thought I should immediately put it on the helproom forum so that (a) someone can advise me what to do (please!!) and (b) tell all other subscribers with vista about this problem...

I was amazed when I looked at the Resource Monitor this morning to find one program - searchfilterhost.exe - that takes up no less than circa 50% of the CPU capacity. This has seriously slowed my computer.

I looked on the www and found this was a common problem... one forum response suggested turning off the .xml file indexing. I did this and this PC became 'normal' but it turned off the search facility, which was then a hassle as I use it a lot... I put the xml indexing back and it slowed again...

I then paused the indexing and that also solved the slow down problem...

It this doesn't look like malware to me...

I would very much appreciate anyone's advice....

can indexing be kept on but maybe in a more restricted manner so that lower CPU resources are used??



  birdface 12:29 04 Dec 2008

Maybe try the solution on here and see if it here

  pdk 12:48 04 Dec 2008

Thanks but I don't think that before a spyware scan (my PC is well protected..) as a first step I need to know more about this searchfilterhost.exec.

Presumably its a Microsoft creation and does anyone else have this issue??


  pdk 12:50 04 Dec 2008

I have fully read your link.... I'll try it and come back to you.... Peter

  pdk 13:04 04 Dec 2008

Switching the service to manual also seems to work... I shall reboot and report back...


  birdface 13:07 04 Dec 2008 here= but so far I have not found a fix.

  pdk 08:41 29 Dec 2008

I found a solution (Microsoft could not help me!!) and I thought I should post it as there may be people out there who will take 2 weeks (like me) to sort it out.

I now believe that malware had taken over searchfilterhost.exe. This was fixed by (a) in the registry HKEYLOCALMACHINE>SOFTWARE>MICROSOFT>WINDOWS SEARCH I found that the key SetupCompletedSuccessfully was changed to 0 - change this back to 1. THEN set up a new index file and a new path in Indexing Control Panel and you should be shoiuld strat inmdexing again...Doing this is of course entirely at your own risk.. take registry back up and set a new restore point just in case... GOOD LUCK!!

  birdface 10:09 29 Dec 2008

Maybe try this. as it has worked for others. [disabling Windows Search in Administrative tools>Services]

  birdface 10:16 29 Dec 2008

Oops you have already fixed it well done.Thanks for the Information it might help others with the same problem.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Artist Helen Friel on designing paper models for everyone to make

What to expect at Apple's 27 March education event

Idées cadeaux pour geeks et tech addicts