Seagate 500 GB Portable drive not being seen

  Housten 18:00 24 Jun 2011

Good Afternoon,

I am really annoyed at the moment at a Seagate 500GB USB portable hard drive. I have a LaCie 500GB dive and it works very well, but it has a ( little ) problem that has irked me for some time – in order to use it I have to power it and that means I have to find a power point. So when I saw the Seagate was USB-powered I thought that I could use it for run-of-the-mill stuff and the LaCie for monthly/quarterly backups. So I ordered the Seagate from Amazon last Sunday, and it arrived just before lunch today. So, after lunch opened it up and set it up and plugged it into my machine, light on unit came on and at the bottom right-hand side of screen box appeared which stated downloading software and drivers. BUT it didn’t appear on the screen ( look round it using Explorer ) or in the list of items that appear when you click on ‘My Computer’. I then tried Seagate’s web site ( not terrifically user-friendly ) and trouble shooter, even downloading their ‘Seatools’ ( 17.1 MB!! ) and installed that on my computer. I even tried their ‘Troubleshooting’ section and the drive is listed under ‘Disk drives’ when I go though @device Manager’ in ‘Control Panel’!! As panic was beginning to set in, I got my wife’s laptop and tried it. Not only did it say installing software but the box appeared offering me the chance to look round it, which I did and saw there were 3 Seagate files on it! I tried it again on my desktop, same as before! I don’t understand this as we both have Windows 7 Home Premium 64Bit so why should her laptop see it but not my desktop? Anyway I ran ‘Seatools’ – not expecting a lot I must admit – but my computer was scanned and it found the drive, so I have run 2 or 3 tests – the last being a ‘Long Generic’ which took it over 2.5 hours! – and it seemed to be working away quite happily, light flashing away merrily. BUT Explorer still can’t ‘see’ it – or at least its not showing on the screen – and if it’s not there I can’t use it. So does anyone have any ideas that will make Explorer display it – with a Drive letter – so that I haven’t wasted my money? Having decided to ask this question I remembered about ‘edenworkshops’ external hard dive not being seen, and saw ‘scotty’s’ reply about needing ‘more’ power. So I thought I had better check this out. I noted that the files on the drive are dated June 2006! Which I found a bit strange, but I have a powered 7 port hub. So I shutdown he computer, connected the hub to a power point, then to the Seagate drive and then to the computer. Switched it on and N O T H I N G! Switched it off, disconnected the Seagate drive and switched it on, OK! Connected the Seagate drive and the light on the unit came on and checked as before. No change!! I have not got a clue what this drive is – or is not – doing apart from making me quite annoyed! Please is there anyone who has any idea what this thing is doing? Many thanks in anticipation

  Fruit Bat /\0/\ 18:37 24 Jun 2011

Look in disk management and assign a drive letter to the drive

  Housten 19:31 24 Jun 2011

Fruit Bat /\0/\

Many thanks - but as I have said before I am brain dead!! Could you, please, explain exactly how I do that. I have had a look and it appears I can get into 'Disk Management' via 'Help and Support', but I can't get beyond that. Sorry to be a pain in the a* but I would very greatly appreciate any ( more ) help you could give me.

Many thanks in anticipation.

  Miké 20:00 24 Jun 2011

Go to ts Start/Run and enter diskmgmt.msc

  Housten 11:34 25 Jun 2011

Fruit Bat /\0/\/Miké

Thank you both! Didn't, initially understand what to with 'diskmgmt.msc', but soon sussed out what to do! There are, apparently 2 partitions on it and I was able to give a letter to the main one, but the smaller - only just over 4 MB could/would not allow a letter to be assigned to it!! This I do not understand, but, I am presuming, it is some sort of recovery programme so I hope I never need to use it, although I will try to find out what's in it!

Anyway, once again many, many thanks to you both. I will try and mark this as resolved!!!!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator of witty, relatable Instagram comics Julia Bernhard touches on our humble moments

iMac Pro review

Quelle est la meilleure application de podcast pour Android (2018) ?