Screen Display Problems with W7Pro

  miner 16:48 07 Jan 2011

I'm running W7 Pro and all of a sudden (isn't it always like that?) the display size including desktop and ll programmes has become slightly too large for the screen (a 23" Sony).

Icons at the edges of the screens are half obscured as is the Start button on the toolbar and the curser will go right off the screen at the sides and bottom - the top is fine.

All the Intel divers are up to date, so any ideas please?

many thanks

  rawprawn 17:25 07 Jan 2011

Have you looked in Control Panel> Display> Resolution? you should be at 1440 * 900. also set Text to Medium

  birdface 17:31 07 Jan 2011

Try holding the Ctrl button down and turning the scroll wheel at the same time till you the size that you need.

  miner 17:45 07 Jan 2011

Thanks rawprawn but the reccomended res for my screenn is 1920 x 1080 and it has worked just fine at that up until this issue. Going to 1440 x 900 just makes everything very large and reduces the resolution accordingly.

Buteman - resizing using Ctrl and the scroll wheel only changes the size of the page in the browser of course. My problem involves the cursor actually going beyond the left, right and bottom of the desktop as do all the progams.

  birdface 17:58 07 Jan 2011

does pressing F11 help or does that make it worse.

  chub_tor 18:00 07 Jan 2011

Is the input to the display from the graphics card DVI or VGA? If the latter you could try the Auto button to re-set the display.

  birdface 18:02 07 Jan 2011

Or make sure the restore down button is pressed next to the red X at the top right.
Then drag the sides and top and bottom to the size that you want.
Make sure no other page is open when doing that.
Then shut down the page by clicking on the red X at the top.
Then see if it stays at the right size.

  birdface 18:03 07 Jan 2011

Or try View.Zoom and shorten the zoom level.

  GaT7 19:40 07 Jan 2011

Did this start to happen after a recent hardware (monitor/GPU) / software (driver) change?

I've been having the same problem off & on in both XP & Win7 for the last 1½ years ever since I purchased a 24" 1920*1200 (was using a 19" 1440*900 monitor with no problems up to that point). At various times, I've blamed it on the monitor, graphics card (GPU) &/or its drivers - as different solutions would work at different times. Sometimes it sticks for a few days/weeks, while at other times it reverts to this behaviour at the very next reboot. It also seems to happen more often on an ATI-based GPU than a nVidia one, & at times with an Intel integrated GPU as well. What GPU are you using?

Anyway, try these one at a time:

1. Right-click desktop > select Screen Resolution > press Detect button. Yes, that's it (this is usually all it takes to resolve it on Win7)

2. Right-click desktop > select Screen Resolution > Change to 800*600, then soon after it changes to this low res take it up to the default 1920*1080 & save

3. Right-click desktop > select Screen Resolution > Advanced settings link > Monitor tab. Untick the box next to 'Hide modes that this monitor cannot display' & save changes. If it doesn't help, try step 2. above immediately after. If that doesn't work either, put the tick back, save & exit.

4. If you're using a nVidia-based GPU, open the nVidia Control Panel (accessible via Control Panel) > Display > Adjust desktop size and position > select the 4 different options one at a time > Apply

5. If you're using an ATI / nVidia-based GPU, open up their respective panels (for nVidia see step 4 above; for ATI it's Catalyst Control Center) & change res from 800*600, then back up to the native 1920*1080 res soon after.


  miner 23:32 07 Jan 2011

Hi G - many thanks for all the suggestion. Nothing worked I'm afraid but I don't have the nVidia Control Panel I find. I've read I need to download the latest drivers for the GPU and then the control panel. I've already got the latest driver it seems so can't download another one.
Maybe I need to uninstall the driver and let W7 look for the new one and then download the control panel.....

  miner 00:00 08 Jan 2011

Hi G, Buteman,Chub_tor, Rawprawn

Problem solved - firstly I slipped up thinking I had an nVidia GPU when it turns out to be Intel!

But worse, I recalled a set-up disc came with the Sony display and this guided me through the set-up menu on the LCD which removed the problem completely!

Simple really!

So apologies for time-wasting....

Best wishes &

Happy New Year!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

Creative studio Omnibus' brand identity for We Said Enough fights back against sexual misconduct

WWDC history: Apple's product launches since 2005

Espace de stockage : comment libérer de la mémoire sur votre iPhone ?