SATA RAID "Incomplete RAID set"

  Chegs ® 07:36 17 Feb 2004

Last night,I removed my IDE HDD to install on my daughters PC(for Linux experimenting)Once I had removed the IDE drive,I went to reboot my PC and was rewarded with...

"Incomplete RAID set,press F4 to enter RAID utility" which I duly did.I could see the two SATA drives,but nothing would get the main SATA drive to boot,until I deleted the RAID set and recreated it.Then I was left with a 240Gb unformatted hdd,and none of my "tools" could recover the deleted partitions.I was left with no option but to set to and reinstall XP and several of my apps(still got another 2Gb's of files left to reinstall)Having sworn and cursed these SATA drives all night,repartitioned them,etc,is there any way I could have recovered the original partitions/files off my hdd's,just so I know.Or,is there another way to reactivate the RAID set without deleting the set and recreating them,as I'm pretty certain it will happen again?

I tried Partition Magic/a couple of recovery tools from the "UltimateBootCD" which claim to recover deleted partitions,but PM didn't bother scanning past about 5% before a message appeared stating there was no recoverable partitions,and the U/B/CD tools scanned thru twice before it too declared nothing doing.I was going to create an image of my Primary partition,complete with Lozzys RamDrive,but as I had been switching the IDE hdd on and off to load Linux(without a problem)I hadn't got round to it(I have XP and DriveImage 5,which only works off floppy on NTFS filesystem)

  Chegs ® 14:47 17 Feb 2004


  Chegs ® 16:47 17 Feb 2004


  Chegs ® 18:19 17 Feb 2004

boing x3

  Chegs ® 21:46 17 Feb 2004

" there any way I could have recovered the original partitions/files off my hdd's...."

  Chegs ® 23:11 17 Feb 2004

My brain hurts....

I have found a couple of links describing a problem with SATA hdd's being setup in BIOS as SCSI devices,which confuses windows as to what these drives actually are and in so doing,the OS shuts them down to quickly causing the data loss that results in the "Incomplete RAID set,press F4" message.There are suggestions of disabling ACPI,to prevent it,also suggested is to boot from a DOS floppy(98 bootdisk)and do the FDISK /MBR command,which is too late for me,but before I reinstall all my apps again,I am going to try the ACPI disabling,and the various other suggestions.There is also comments from George Breeze(the SB + Via fixer from kt chipset fame)

The pages are here click here

and here click here and rather heavy reading(but interesting none the less)

  Chegs ® 04:22 18 Feb 2004

I tried the disabling of ACPI,its very easy to make a mistake,so if you opt to try this route,ensure you have enabled either System Restore,or have an image of your C: drive to work with.I also updated the hdd firmware recently,so didn't need to try this(I did the Silicon Image controller at the same time)and decided this had increased its stability,but after lastnites fiasco...

  Chegs ® 18:37 18 Feb 2004

Anyone any comments?

  Chegs ® 01:43 19 Feb 2004

I would have thought,with the number of SATA hdd users in PCA,someone might have been interested enough to comment on this thread,but looks like I was mistaken.

  Chegs ® 14:41 12 Sep 2005

? Just to bring back into My Postings,as on my PC I can only get back 25 pages.

  Chegs ® 20:46 23 Sep 2005

To bring to the attention of alan 14

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

Inside the iMac Pro - Apple's most powerful Mac yet

iMac Pro release date, UK price & specs

Football : comment regarder la Ligue 1 en direct ?