manchesterblue 13:00 04 Jan 2009

Hi people,

I was wondering if someone might help, I've been trying to connect 1 SATA hard drive (boot drive) and two IDE devices (IDE hard drive: Seagate barracuda 7200 160 gb without OS. CD-ROM drive: Optiarc DVD RW AD-5200A ) to my system with no luck. I can only seem to get one or the other to work (they both work fine on their own) with my SATA HDD: Hitachi HDS721616PLA380 160gb.

I have been through all of the master/slave configurations on each of the IDE drives without success trying all combinations of jumpers and cables I also tried new cables. In the BIOS: ( American Megatrends Inc. P1.50 06/30/2008), I have tried each of the boot options ie. sequence and hard drive select and also all IDE/SATA configurations. I have also tried sata/ide combination. No luck.

I have tried these combinations using the three devices and also the two IDE devices without the SATA drive.

I ran a memory check with mem86 with no faults and have checked all internal and external cables in the pc. The computer itself is only a few weeks old and runs fine until I try to add the extra ide device. I suspected PSU may be at fault but since it is new and there are no other external devices attached to the machine I doubt it.

I have also updated all drivers including the chipset for the motherboard but as yet I havent updated the BIOS.

At present I have connected the sata hard drive via the red connection lead to the sata controller on the mobo and the two IDE devices via the 80 pin ribbon cable to the IDE controller with the Hard drive as master and the dvd-rom as slave (this is per the mobo manual instructions)
Any suggestions?
Mother Board: Wolfdale1333-D667 (ASROCK)
Memory: 2 GB
OS: Windows XP Professional Service Pack 3 (build 2600)
Processor: 1.60 gigahertz Intel Celeron dual core
PSU: Win Power ATX-400

  Technotiger 13:04 04 Jan 2009

IDE drives would run fine in External USB Enclosures.

  Pamy 13:06 04 Jan 2009

When all connected as per manual, does the SARA drive boot up into windows. If so can you see the other drive in disk manager?

  Pamy 13:07 04 Jan 2009


  manchesterblue 14:19 04 Jan 2009

Hi guys,

The SATA drive boots up fine but I can only see either one or the other IDE drive in windows or even in the bios no matter which configuration (jumpers/cables/bios settings) I use. It seems to me that I can only get one device at a time to work with the IDE channel.

I vaguely remember hearing some time ago about this particular hard drive (Seagate barracuda 7200 160 gb) being difficult to install with other devices on IDE but unfortunately I only have a single IDE on the mobo. I cant remember the details or even if thats been verified. I was hoping someone else might have heard too and know of a fix.

  ambra4 14:35 04 Jan 2009

You can use the SATA ports by connecting a SATA to IDE adapter to your present IDE drives

SATA to IDE Dongle

click here

  Pamy 14:35 04 Jan 2009

Instead of Master and Slave for the IDE devices, have you tried Cable Select?

  manchesterblue 15:55 04 Jan 2009

@ ambra... thanks for that but Im more concerned as to why these two devices wont work on a single ide channel.

@ pamy... As I've said, I've used all possible luck I'm afraid.

I decided to pull another old dvd drive out of another machine and I found that when connected to IDE its recognised but only with the other DVD drive. When I tried it along with the IDE HDD it wouldnt work. It looks as though I was along the right lines when assuming that this HDD does not like sharing an IDE channel. I would have thought that Seagate would have realised how important it would be to make their drives fully compatible with any other device while sharing an IDE channel.

Anyhow, Unless someone knows something I've overlooked I'll mark this question as closed in a while. Thanks for your time.

  LastChip 16:01 04 Jan 2009

go to Seagates site and see if there is a firmware update for the drive.

If it's a known problem, there may be.

  manchesterblue 17:14 04 Jan 2009

@ Lastchip...thank you for making me consider the obvious and realising how dumb I've been.


I went onto Seagates site and found the jumper configurations for the drive. I found that there is a further configuration other than simple master/slave. By adding a second jumper I was able to configure the drive to : Master with non ATA compatible slave. It worked. I must therefore apologise to Seagate considering my previous post however, in my defence, why do manufacturers make their configuration illustrations impossibly small and difficult to read?

Thanks to all for taking the time to help.

  Technotiger 17:23 04 Jan 2009

Grreat, thanks for your feedback, it might help others in the future.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Social Media has Propelled Political Graphic Design and Art in the Last Decade

The best kids apps for iPhone & iPad 2018

HomePod d’Apple : date de sortie, prix et fiche technique