Sata Controller Fault

  SantasLittleHelper 12:17 01 May 2006

Hi all, I am trying to install a 160Gb Maxtor SATA hard drive on my computer, an AMD Athlon 3200 XP on a MSI KT6 Delta motherboard with 2GB ram. When I go into "Control Panel", "System" then "Device Manager", it shows an exclamation mark by the VIA Sata Raid Controller, and when I go to properties for this device it says "This device cannot start". Up to now I have made sure that Sata is enabled in the Bios, downloaded and installed the latest drivers from the Via website, tried the drive connected to both Sata plugs on the motherboard but still no luck. Has anyone come across this before, and managed to resolve it?

  AndySD 13:24 01 May 2006

MSI Drivers click here

Also try using live update 3 and see what version your BIOS is as there have been some updates for the SATA system click here and have a read.

  SantasLittleHelper 17:04 01 May 2006

Hi AndySD, I have dowloaded and installed all the latest drivers and any Bios update. I still get the message "This device cannot start", but no clues as to why it cannot start.

  AndySD 17:08 01 May 2006

Right click on My Computer and choose manage then choose Disk Manager can you see the disk there?

  SantasLittleHelper 18:47 01 May 2006

No ,it isn't listed in disk manager

  SantasLittleHelper 18:49 01 May 2006

p.s. should I disconnect the IDE drive it is booting from at the moment, or doesn't it matter?

  AndySD 07:03 02 May 2006

Nope it should be fine. Go back to the bios and make sure SATA is enabled and then enable Reset Configeration Data.

Now go to Add/Remove Programs are the raid/sata drivers there?

  SantasLittleHelper 13:40 02 May 2006

Hi, have double checked Sata is enabled in the Bios, all o.k. Cannot find "Reset Configuration Data". Have also uninstalled "Via Sata Raid Controller" in device manager and rebooted. It came up with "Found new hardware" when I rebooted and proceeded to load the drivers for it, then asked to reboot. When I rebooted and went into Device Manager, the exclamation mark is still there and it reports in properties that "This device cannot start". p.s. if I disconnect the old hard drive and just leave the SATA drive connected, on boot up I can see the hard disk light blinking, and I can hear the disk spinning, but it does not recognise it, so I assume that it works o.k.

  AndySD 14:30 02 May 2006

Try installing the click here VIA PATA/SATA IDE Driver Package

  SantasLittleHelper 20:39 03 May 2006

Hi, I am back on line now, had to do a complete re-install of windows. Have downloaded and installed as you suggested, but the drive is still not recognised.

  SantasLittleHelper 13:37 06 May 2006

Have just noticed that if I boot up with the SATA drive disconnected, my C: drive is a IDE interface, the exclamation mark dissappears from the SATA Raid Controller in Device Manager, and it reports that the device working properly. It appears that the fault "This device cannot start" only appears when the SATA drive is connected. Any ideas anyone? I have now been six days trying to get this drive to work.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

HomePod review

Les meilleurs logiciels de montage vidéo gratuits (2018)