Samsung S2 USB 2.0 1TB Ultraslim Portable Hard Drive

  exdragon 16:14 06 Nov 2012

Hi - can anyone sort out what I'm doing wrong with this, please? I bought it on the strength of reviews on Amazon, and wish to keep my Lightroom catalogue on it.

All of a sudden, it says it needs formatting (it's pre-formatted NTFS),and when I use it with Lightroom, this program stops working and closes down, whereas previously it was working ok. I keep getting a screen headed Samsung Drive Manager popping up, and on a random basis, it says it's installing the driver software.

I have a couple of other external drives and simply plugged them in and used them, so I'm obviously doing something wrong. I can't find anything on the Samsung website.

Any ideas, chaps?

  Fruit Bat /\0/\ 16:44 06 Nov 2012

yes Norton should be giving you ample protection so probably just a windows glitch which sfc should cure.

  exdragon 16:50 06 Nov 2012

Fruit Bat /\0/\ - sorry, I don't understand - where does Norton protection come into it??

  lotvic 16:56 06 Nov 2012

I believe Fruit Bat /\0/\'s post should have been on nissanalmera's thread not on this one.

Samsung Drive Manager, I think I remember another thread with the same problem, I'll have a search and see if I can find it. I think solution was something along the lines of stopping Samsung Drive Manager from automatically starting.

  exdragon 16:59 06 Nov 2012

Thanks, lotvic - I feared I was getting a little more confused than usual!

  lotvic 17:06 06 Nov 2012

Seagate have taken over the support of Samsung ext hard drives. This explains about the Samsung Drive Manager

  exdragon 17:48 06 Nov 2012

Many thanks - I'll have a look after my pre-prandial G&T!

  Fruit Bat /\0/\ 18:05 06 Nov 2012

How did that post get in here? This is first time I've looked in this thread.

My apologies to all concerned.

I bought a lacie drive that gave me similar problems and had to disable the inbuilt programs to get it to work properly on my XP system.

  lotvic 18:25 06 Nov 2012

Fruit Bat /\0/\, I sometimes get the wrong thread heading on tab when I open a thread.. By that I mean the title of the thread doesn't match the title on tab in Firefox. Next time it does it I'm going to post on the thread and see which one it appears in ;)

  exdragon 23:30 07 Nov 2012

Problem solved: a reformat got seems to have worked.

  exdragon 23:31 07 Nov 2012

Hmm, ignore the'got'

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy Fold review: Hands-on

Best Wacom deals for Easter

iMac 21.5in (2019) review

Comment faire pivoter une vidéo ?