Sagemcom 2704n won't connect withwindows xp

  Rob737 19:23 25 Jan 2018
Locked

Having been with BT for years using a home hub 3 for broadband I've switched to John Lewis for phone and broadband. Having plugged in the sagemcom 2704n supplied by them my windows xp desktop won't connect to the internet. My tablet/phone do over the wifi. The guy on the help line say the problem is with my computer and I need to [pay to] update my computer.

Any thoughts? (If I'd known it was going to be a problem I'd never have switched! - "If it ain't broke don't fix it")

Rob

  Fruit Bat /\0/\ 20:29 25 Jan 2018

Are you connected by cable to the router?

  Rob737 22:13 25 Jan 2018

Yes I am

  beeuuem~2 22:38 25 Jan 2018

I have the same router, although supplied by Plusnet, and it works fine on XP (and W7 and W10)

How far does it get in the connection process?

  beeuuem~2 23:01 25 Jan 2018

Can you see the router in a browser window or pingthe router ?

  Fruit Bat /\0/\ 23:51 25 Jan 2018

Assume you are using IE, have you got the correct password and settings in Network and connections?

  Secret-Squirrel 12:21 26 Jan 2018

Rob, simply connecting the Ethernet cable from the router to your desktop is normally all that's required to get an Internet connection, so as beeuuem~2 asked, what goes wrong exactly? If you get any error messages then post the details in full.

By the way, for your setup you don't need to enter any passwords. If you start fiddling about with passwords in the Network section then you'll only make things worse.

  Rob737 13:01 26 Jan 2018

When I try to connect it just says it cannot display the webpage.

Diagnostics give HTTPS Error 12029 A connection with the server could not be established, then HTTPS Error 12157 An error occurred in the secure channel support. There is also 'Could not make an FTP connection'.

  Fruit Bat /\0/\ 13:54 26 Jan 2018

Internet Explorer - properties - connections tab - make sure box Optain Ip address automatically is tck - click Ok.

  Rob737 14:35 26 Jan 2018

Thanks Fruit Bat. No such box in the connections tab exists though, nor in the Advanced tab.

  beeuuem~2 15:09 26 Jan 2018

On my XP with IE8 - open Internet Explorer> Tools> Internet Options > Connections tab > LAN settings button - tick ' automatically detect settings' click OK and exit.

Although this isn't set on my PC it has been known to help with connection problems.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei Mate 20 Pro review: In-depth hands-on

See concept art from groundbreaking video games including The Last of Us, Journey and No Man's Sky

iPhone XR release date, price & specs

Les meilleurs VPN pour Kodi (2018)