Safe Mode Boot only - System Restore works for 1mn

  SYNCHRONIC 10:31 18 Nov 2016
Locked

Hi there

I've been having a nightmare of a week with my PC after trying to resolve some microstuttering/DPC Latency issues, I will try and list the stages concisely here.

  • Powered external USB Hub via generic 9v power adaptor to reduce strain on USB ports

  • Worked fine for the day, then next day after turning on computer all USB ports were non-functioning/fried from over powering perhaps

  • Installed PCI USB 1.1 card, USB devices worked ok for 1 day

  • Next day the mouse was not able to move, however it could still click/scroll, same symptoms on another computer, old Microsoft mouse worked fine with both PC's

  • Bought new PCI USB 2.0 card, worked fine for a day (apart from the non-moving mouse)

  • Crash/freeze with grey screen (never seen this before on any system)

  • Unable to boot past black screen just after "Starting Windows" screen

  • Works in Safe Mode, chkdsk and sfc scan report no issues

  • System Restore works and I can boot into Windows normally

  • 20 seconds later Device Drivers are installed and the USB devices stop functioning (mouse and keyboard, but PS/2 keyboard still works)

  • Back to not being able to boot past Starting WIndows screen, only safe mode works...

I am going to try and remove all non-essential drivers, but I cannot seem to find a program that can do that for me, my second plan is to do a "Repair Install" of Windows 7 Ultimate, however I've heard that can make some installed programs unable to run, which I want to avoid as much as possible (I have over 100 programs installed, many of which I no longer own the installation media to, so a reformat is also out of the question for me).

If anyone has any ideas/tips/advice it would be hugely appreciated

The funny thing is the microstuttering/glitches/crashes/DPC Latency all stopped after my USB ports got fried (as USBPORT.SYS was the driver causing the most latency as reported by the "LatencyMon" software). But now it has all gone extremely downhill, to the point of only being able to run the computer in safe mode.

Thanks again!

  Fruit Bat /\0/\ 13:55 18 Nov 2016

Us ethe free USB device view to show all usb devices connected to the machine

use it to remove ALL devices and it will clear the registry of all USB driver info

Reboot the PC and plug devices in one at a time and they should be recognised and drivers installed

click here

  SYNCHRONIC 15:47 18 Nov 2016

Thanks Fruit Bat, I will give this a shot.

On a related note, do you think I should disable all the Intel USB family controllers/root devices since I am not actually using any of the built in USB ports and only a PCI USB card which appears to be using it's own drivers.

Thanks!

  Fruit Bat /\0/\ 16:16 18 Nov 2016

Uninstall rather than disable

if its a driver problem they won't pass data , if its a power problem then won't work at all.

Have you tied plugging something in to see if it will charge off the USB ports then you know if they are fried.

  SYNCHRONIC 16:51 18 Nov 2016

Before the inability to boot normally I tried uninstalling the Intel USB controller/family drivers, but they would automatically reinstall next boot. Disabling them did not affect the usage of USB devices plugged into the PCI USB card though.

Yeah the old (fried) USB ports still cause my devices to "light up", my gaming keyboard backlights would turn on, and the mouses backlight would flash for a split second, but neither would be resonsive, even after all sorts of variations of uninstalling drivers in device manager, installing drivers manually, automatically installing them on reboot etc... the mouse somehow got more and more unresponsive over a couple of days.

  Fruit Bat /\0/\ 18:03 18 Nov 2016

Yes they get reinstalled on a reboot but won't work possibly because of driver conflicts in the registry hence the program to clear all the drivers from the registry before rebooting.

  Govan1x 18:16 18 Nov 2016

System Restore works and I can boot into Windows normally.

Maybe try it again and this time go into services and disable windows updates. Restart and see if it works ok. if so probably a bad driver being downloaded from Microsofr.

If you had Windows updates set to run automatically change it not to look for updates then you can decide what updates you want to install.

Also have a look in device manager for any yellow exclamation marks as sometimes a faulty Driver will give you problems.

  SYNCHRONIC 18:57 18 Nov 2016

I've ran the program to uninstall all USB drivers, as well as another program to remove all display drivers, as well as "DriveCLeanup" to remove remnants of unused/overwritten drivers.

All was well in normal booting, started with nothing external plugged in except PS/2 keyboard. Then the only thing I installed was the AMD graphics card drivers, rebooted and then back to the not getting back "Windows is Starting" phase.

Definitely seems the graphics card is causing the major issue here, even though that seems very illogical considering the issues revolving around USB ports, and the PCI USB cards (both of them) that I have had experiencing troubles with over the past few days.

I'm going to try uninstalling all display drivers + USB drivers, reflashing the bios, then trying out an older graphcis card driver from say 1 month ago or so.

Otherwise, is there any sure fire way to see if somehow my graphics card has been damaged by the USB hub excess voltage or something?

Also as an addition Windows Update is disabled and has been for about 6 months or so, and no yellow exlamation marks in device driver.

Thanks again for all the help!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Redmi 8 Release Date, Price & Spec Rumours

Candid photography at home is helping Swedes to sell houses

New Apple Products 2019: Predicting the new Apple products coming soon

Les meilleures séries Netflix