Running old external hdd + formating etc

  Furkin 11:45 21 Nov 2012

Hi gang,

I want to check the contents an old hdd before I get rid of it. It’s taken me 2 days to remove it from the Polar Tower case – not sure what the form factor is, but it takes a large Legend QDI m.board. I had to strip the whole case down to get at one retaining screw in the base of the drive !

The drive is an IBM DTTA-351010 E182115HG (IDE). I’ve Googled it & it seemed to be a good bit of kit – at the time.

I’ve connected it to a USB via an Adapter Cable kit – to my SATA desktop. I’ve used this on other HDD’s, & it was o.k.

The drive starts & runs o.k. The lights on the adapter work o.k. The machine recognises that I have another drive (set to Master), but won’t let me open it. It says it needs formatting. I’m guessing that its formatted to FAT/FAT32 – my machine is NTFS.

Of course, if I format it, I’ll lose everything on it.

I don’t recall having this problem with the other hdd’s that I’ve looked at, but I can’t really remember what either they, or my machine, was formatted to at the time.

Any ideas how to get round this please ?

As a last resort - and if I can find a PS2 rodent & k.board - I may be able to get it running in the original Polar case.

Many thanks

  lotvic 12:27 21 Nov 2012

have you looked in 'Disk Management' to see what info that gives/recognises on File system?

Is your desktop running XP or W7?

  lotvic 12:30 21 Nov 2012

I found this AskLeo which is about what you are trying to do, it might be useful.

  Furkin 12:40 21 Nov 2012

Asus M5a-78 + Phenom IIx2 + IE9 + Win 7 32bit + 4gb ram

That looks like the very thing - thanks. I'm off to the hospital shortly, so will look into it when I get back.

It had already assigned its-self as G:\ drive.

cheers mate.

  lotvic 12:49 21 Nov 2012

That might not be the very thing :( as it's already assigned itself a drive letter.

  Furkin 09:58 15 Dec 2012

Hi guys, Apologies for the delay in getting back – I’ve been ill.

I’ve just sorted a problem with my Sons hdd (with the help of you guys) which prompted me to get back to my own problem.


I’ve connected this up again to remind me of what happened.

When I go to Computer, it recognises it as a drive and assigns G: to it. It doesn’t say anything about a file system (FAT/NTFS etc) – whereas my Samsung & Seagate 1tb drives show up as NTFS’s.

When I click on G: it comes up with:

“Needs formatting before you can use”.

Then I get:

**“G: is not accessible.” The volume does not contain a recognised file system. Please make sure that all required file system drivers are loaded & that the volume is not corrupted”.**

This came off the machine that I was using before this one, so I can’t see it being empty, though I guess it uses the older file system.

I haven’t missed much that might be on it,,,, but that might just be because I don’t know what’s on it ?!

As you said lotvic, the 'askleo' wasn't for my problem.

any more ideas please ?

  lotvic 13:03 15 Dec 2012

Only to see if EasUS PM can recognise the file system. If it can't then I'm out of suggestions.

  Fruit Bat /\0/\ 13:46 15 Dec 2012

if it came out of an old machine using window it will either be Fat32 or NTFS

If windows sees the drive and assigns a letter then either nothing on it or File allocation table is damaged.

Test Disk will recover it if there are files there

How to use Test Disk here

  Furkin 01:15 16 Dec 2012

Thanks F.B. for the update.

I have managed to get to read this drive, on my machine. When I set it as Master, I was looking at the wrong list of disk features. When I set it as 16 Head - it now works, and is FAT32.

I'm currently looking through it, & deleting old stuff.

My next problem, is getting it to actually run in its own machine.

I can't recall the error messages at the moment, so will start another post tomorrow (Sun) with images of them.

thanks again to you all.

  Furkin 14:53 26 Dec 2012


Hi guys, Apologies for taking up your time, but I tried to carry on with this drive today.

I think there is now a physical problem with this drive. When I managed to boot it up a couple of weeks ago, all seemed well. I looked at the files/folders, and deleted a couple of them, intending to carry on with it later.

But: when I connect it up now, the PC reverts back to its original message “needs formatting”. I have tried most permutations of jumpering – to no avail. When its powered up, I can hear/feel it spinning and all seems nice and smooth - until I connect the USB data cable. It then starts to make a couple of noises;

One is a slightly quickening whirring sound for about a second, then there is a ‘click’, and it goes back to the whir – on a loop.

To my limited mind, it sounds as if its trying to read the disk, but gets mechanically stopped.
*If its anything like a laser arm in a CD/DVD thing, the laser carrying arm sometimes sticks. I’m wondering if this might be what’s happening here.*

I only want it to work once more – then I’ll copy the data to my internal E: (back-up) drive.   I looked at a thing on youtube about opening similar items, so that I might be able to see what’s happening, but the video only showed him taking out 6 screws around the edge of the cover. Mine has similar 6 screws, but another 3 (poss more under the label). One seems to be in the middle of the platter – so I don’t want to remove this without seeking help.  

Is anyone conversant with this drive – intimately ?  

I’m hoping that a little nudge might make it work one more time.

Whilst its not the end of the World (I missed that day !? What occurred) I’d like a bash at both retrieving the data again, and also making it work properly – after all, I’d like to put it back in the old machine that it came out of.

  Any help or advice would be appreciated.

  Hope you’re all having a great time.

  lotvic 15:36 26 Dec 2012

Yes, sounds (clicking) as if it's getting stuck and is nearly duff. you could try shaking/tapping it to see if that unsticks it. With my dodgy clicky - now it works, now it doesn't - oldie I ended up putting it in freezer overnight (double wrapped in plastic to keep moisture out) then took it out and after a couple of hours tried it again and was able to copy the entire contents to another hard drive.

When I tried the oldie the following day it was dead again, so it got the lump hammer treatment (as I couldn't get top off to smash the actual disc inside) prior to being dumped in bin. If you are wanting to have a working hdd in the old pc you could make an image of the oldie and then you will be able to put it on a different drive and boot the old pc up.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro (2019) review

Inside the redesign of the world's largest computer games platform, Steam

Apple Streaming Service Release Date & Apple TV Subscription Rumours

Quel antivirus gratuit choisir pour un PC ?