'run a dll as an app' error

  OllieHall 13:41 27 Nov 2005
Locked

Hi there,

I haven't posted for ages, but having come across an irritating widows error yesterday i thought i'd see if anyone has any advice.

I'm running Windows XP SP2, and frequesntly run Ad-Aware, Spybot, AVG Free, A-squared, and Antiy Ghostbusters.

My problem is: when attempting to change my desktop image through the Desktop properties menu, either the image browser dialogue box simply vanishes without when browsing my pictures folder, or when selecting the image to use, throws up an error stating that 'run dll as an app has failed' followed by another error saying that drwatson has also failed. Both of these generate error reports, but following the sending of the reports nothing happens. The desktop properties window then hangs, and on shutdown run32dll is not responding.

This is quite odd and starting to get on my wick!

Any advice? Thanks in advance.

Ollie

  OllieHall 13:43 27 Nov 2005

sorry, it's 'rundll32' that's not responding.

cheers

  OllieHall 14:15 27 Nov 2005

I've done a bit of research and found that it's a known problem - I have 2 rundll32's running in my processes list.

Searching for the file gives me two entries:

1 under C:\I386
and 1 under C:\WINDOWS\SYSTEM32

and 13 .pf files.

I've tried to terminate one of the processes - mem usage 25,968k! But nothing changes.

Does anyone have any advice as to how I can get rid of this malware for good??

  Skyver 15:13 27 Nov 2005

DO you already have desktop wallpaper? If it's a huge (1mb+) jpeg from a camera it can make the desktop wallpaper dialogue crash.

  OllieHall 15:17 27 Nov 2005

Hi Skyver,

I do, but it's only 270kb. :-/

  Skyver 15:20 27 Nov 2005

Have you run a System File Check? Startmenu/Run, type `sfc /scannow` - have your XP CD handy. Are your graphics drivers up to date?

  OllieHall 18:04 27 Nov 2005

I'm going to give that a go.

The graphics drivers are up-to-date.

  OllieHall 18:26 27 Nov 2005

Hi Skyver

The System File Check ran without a hitch

I found this thread on annoyances.org:

click here

But it looks as if the solution (identical syptoms) might be quite specific to the source of the infection. :-/

Thanks for your time btw ;-)

I guess i'm lucky that this is my first encounter with a 'nastie'.

Ollie

  Skyver 18:33 27 Nov 2005

Seems you're right; It could be some obscure registry entry that's been corrupted - if you feel inclined, run this (click here
) in the background and access the desktop properties as usual - take a look at the entries listed in Regmon (there will be loads, use filtering once you've seen what executables you need to allow) and see if it's missing any registry entries. There will be some `fails` on any system but it's worth a look. Also, does the same thing happen in safe mode?

  OllieHall 18:43 27 Nov 2005

Thanks Skyver.

I'll definitely try that.

I have to admit I didn't try to change the desktop in safe mode!

Let's see what happens with regmon.

Cheers,

Ollie

  OllieHall 19:12 27 Nov 2005

Well.

Can't locate anything dodgy using regmon :-(

Unless i'm just missing something.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HP Envy x2 review: Hands-on

Iconic New York graphic designer Milton Glaser on his uplifting new subway posters

New iMac Pro release date, UK price & specs rumours

Comment suivre le parcours du père Noël ?