ROM drives not detected

  Buachail Mór 13:30 21 Nov 2003

I have little info so far, but would like some pointers for before I start the job...

A friend says her PC no longer recognises the dvd-rom / cd-rw drives on her pc. I got her to look in device manager and they are not there. So she rebooted and during the startup sequence only the hdd was recognised as primary master - no primary slave, no secondary master or slave.

The machine is a Time 500mhz with 128mb ram from what she says about the startup sequence. I remember installing the CD-RW drive about this time last year and think that it went on as primary / slave.

I said that I will come to have a look at the machine next week but in the meantime would like some suggestions as to what I should be looking for. Is is possible that this is a hardware problem? How might I best diagnose what is wrong and thus search for a solution?

Thanks very much and apologies that this will not be solved for some time... Wednesday / Thursday at the earliest when I get to see the machine. But as I say, I want some suggestions for now.

  Stuartli 13:41 21 Nov 2003

It's possible that your IDE cable or the leads to the drives have become disconnected or loose.

If the drives are listed in Device Manager in Safe Mode then the loose or disconnected cable/leads is the most likely cause. Particularly check the motherboard connection.

The CD or DVD-ROM drive should be set as Slave and a rewriter as Master.

  Buachail Mór 13:48 21 Nov 2003

Thanks Stuartli - no, they are not in the device manager. I will check the cables - I had not thought of that as the machine has not been moved

  rocketronnie 20:51 21 Nov 2003

what o/s i have just loaded xp pro and i have cannot get pc to find cd in the drive?

  alan 2273 23:58 21 Nov 2003

Dell comp P4 1.7gh 256 mb sdram dont know what the mobo is as it is a friends comp.
To enable the USB ports you have to go into device manager, disable the 2 ports then enable them again and they work till you switch off then unless you repeat this process when you switch on again they don`t work. the os is xp pro and the bios says the controllers are enabled and on.
Has anyone got any ideas?

  alan 2273 08:47 22 Nov 2003

Apologies for hijacking your thread, I meant to start a new thread but somehow attached it to yours.

  Stuartli 08:54 22 Nov 2003

Did you appreciate that I stated if they are listed in Device Manager in Safe Mode ...?

  alan 2273 23:31 23 Nov 2003

Just a thought if the dvd rom and the cdrw jumpers are both set at master and are on the same ide cable it will not be recognised in device manager

  Stuartli 15:14 25 Nov 2003

May be useful help here:

click here

Read through the various articles.

  Buachail Mór 07:53 26 Nov 2003

I am home again and will have a look at that machine tonight. Thanks very much for all the advice so far.

Stuartli - yes, I accepted what you said re. safe mode - they are not there either. Apologies for not making that clear.

alan 2273 - the thing is that both worked fine up until a week ago or so, and that is the cause of my concern - nothing changed. Consequently I am hoping that there was some movement of the machine which caused the cables to come off.

I will post back either late tonight or tomorrow night.

  Buachail Mór 11:15 29 Nov 2003

Still not had a chance, but appreciate all info above. Will give it a go over the next few days I hope.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Artist Helen Friel on designing paper models for everyone to make

What to expect at Apple's 27 March education event

Idées cadeaux pour geeks et tech addicts