Replacing mbr to remove Grub

  dms_05 08:04 27 Jan 2010

I've tried running a Linuc distro from an external HDD. It dual boots W7 and OpenSUSE. I'd now like to replace Grub and revert to just W7 from the internal HDD.

I've tried bootsect /nt60 all> after trying just C: but Grub remains as the boot loader.

Where else might Grub be hiding and how do I revert to just W7?

Any ideas?

  dms_05 10:31 27 Jan 2010


  gengiscant 10:36 27 Jan 2010

Anything here to help?click here=

  dms_05 10:56 27 Jan 2010

I've tried the 'official' method by using bootsect from the Repair option - by booting from the W7 DVD. However whilst the mbr is undoubtabley repaired (one assumes to the original W7 settings) the bootloader used when starting my laptop still boots via Grub. As I finally tried the 'all' syntax with bootsect I have repaired all the Windows partitions.

So I assume Grub is hiding somewhere else (maybe on a Linux partition) and I was looking for help on locating Grub and replacing it with a bootloader from the W7 partition.

  gengiscant 11:13 27 Jan 2010

I really know little about what you are trying to do, so forgive me if my attempt at helping is worse than useless.
Would EasyBCD be of any here

  dms_05 11:23 27 Jan 2010

Any help is appreciated!

I have used EasyBCD in the past (with Vista) but I've not tried it with W7. Maybe now is a good time!

  Zeppelyn 14:45 27 Jan 2010

Trying booting from the Win 7 DVD and then access the command prompt option. From the command prompt type bootrec.exe /FixBoot and hit enter.

  dms_05 15:04 27 Jan 2010

Thanks Zeppelyn - just tried that and no change, the laptop is still looking to boot from Grub.

It seems I've somehow managed to get two active partitions (essentially my Windows C: drive and my Ext USB HDD G:) and the laptop is looking to the G: drive where Grub seems to be located.

I can't find a way to make C: the only active drive, which may solve the problem.

I will try uour suggestion again but trying to point the bootrec command at drive G:.

  dms_05 15:53 27 Jan 2010

Success. I needed to run <BootRec.exe /FixBoot> after changing to the drive causing the problem. As the Command Prompt lands you at the X: prompt I changed Drive to G: and then ran <bootrec.exe /FixBoot>

  Poitier 16:06 27 Jan 2010

Hi I am not familiar with Win 7 but grub will be located at the beginning of the first ext3 Linux partition.Found this link which seems to have worked.
click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Wacom Cintiq Pro 24 and 32 review – hands-on

When is the next Apple event?

Gmail : comment annuler l’envoi d’un e-mail ?