Repairing faulty or damaged bios using usb or cd

  woodman-46 16:07 15 Jan 2012

I have been trying to get my wifes Acer laptop up and going after it malfunctioned a while back. when power is pressed the HD and fan spin but the screen remains black with a flashing cursor top right hand corner. I can get into the bios by pressing f2 on startup but f8 does not work but just makes a beep giving the impression it is not working. I cannot enter safe mode because of this. I have also tried the return to default option in Bios with no luck I have been reading a lot of advice on forums and one which I have below gives a solution that might work in a situation like this and I would at least like to try and give it a go.The advice the person gave is below in inverted commas.

"Well my GF's Acer Aspire 5720 doesn’t always connect to the router at home, so I guessed it was the wireless drivers, as my iPhone and sisters laptop always connect fine.

After an update, which didn’t solve the problem, I thought I would try a BIOS update, V1.17 to V1.42 - quite an upgrade.

Well the winFlash file opened, erased the bios, then failed on "VALIDATE FAILED" error AFTER ERASING THE BIOS FFS!

Press the power button, hard drive cycles continuously, screen doesn’t turn on, it was a brick.

After some reading I found something quite fantastic, if your laptop has a PHOENIX BIOS, you can do the following to revive it from being a brick.

  1. Download the BIOS from the manufacturer’s site, preferably the version that worked originally.
  2. Burn ONLY the .FD file to the CD.
  3. Remove the Battery and Power Cable from the laptop.
  4. Open the CD Drive with a Pin (Push a pin into the hole on the drive to force an eject)
  5. Put the CD with the original .FD BIOS file into the drive.
  6. Hold the FN and ESCAPE keys down.
  7. Plug the MAINS LEAD ONLY into the laptop.
  8. Press the power button whilst still holding the keys. a. This will FORCE the computer to load the .FN file from the CD and write it to the BIOS of the machine.
  9. The laptop will power up, you can release the keys; leave the laptop for 20-30 minutes if needed.
  10. The computer will turn itself off once complete.
  11. Re-insert the battery, power on the laptop.
  12. It works a. In my case – Happy GF. I tried the version that failed the update on my laptop first, and it did not install, I downloaded the 1.19 version (closest I could find for my BIOS to 1.17 [original]) and it worked.

Hope this works for anyone that experiences this problem, thought it was a pretty awesome fix, and worth people knowing."

Iwant to try this but when I download the relevant bios for the Acer 7110 which is the v1.24 and extract it has about 6 different files but none are .fd which is mentioned in the post above. I gather this was included in older bios but maybe not in more up to date ones. Does anyone have any idea how to locate this. By the way many people replied to this posters advice to say it had worked for them. If this is not a possible fix nowadays can anyone put down in real laymans terms for a "newbie" like me a simple method of creating a repair disc (usb or cd) that the laptop might recognise and use to repair itself. The laptop is an Acer 7110 and the biuos available from the Acer dowload site is v1.24 Thanks in advance.

  Fruit Bat /\0/\ 16:30 15 Jan 2012

BIOS flashing is always a last resort as if it goes wrong then you have wrecked an expensive computer.

when power is pressed the HD and fan spin but the screen remains black with a flashing cursor top right hand corner

symptoms of unable to find hard drive.

to prove your machine is good try booting from a Windows DVD or live linux CD

also try remove / refit of the hard drive.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

See iconic duo Smith and Foulkes' epic animation for the BBC's Winter Olympics coverage

iMac Pro review

Idées cadeaux pour geeks et tech addicts