Hot Topics

Removal of Corrupt Documents

  johndrew 12:50 01 Jan 2012

I have two documents that were sent by e-mail and have a .docx suffix. I saved them to My Documents folder but have the original e-mails as well. Both claim they are opened using Word but when this is attempted they report they are corrupt and cannot be opened. They open correctly from the e-mail attachment location.

It is not possible to change the suffix to .doc, .txt, .old or any other suffix - again because they report as corrupt - and all attempts at deleting them using deletion tools (Unlocker, Glary Utilities, Spyware Terminator removal tool and similar) have failed. They cannot be moved to any other location either.

I tried booting fro the UBCD disk and deleting when not actually booted into Windows, but this also failed.

Does anyone know or can suggest a method to remove these documents from my PC?

With thanks in anticipation.

  Fruit Bat /\0/\ 13:13 01 Jan 2012

What version of word are you trying to open them with?

MS compatability

  johndrew 15:03 01 Jan 2012

I'm using Word 2002. But I'm not sure what you are saying given the documents attached to the e-mails open correctly in the same program??

As an aside your link fails to load - it simply is 'Waiting for...' continuously.

  Drum 16:27 01 Jan 2012

Link worked fine for me.

  Fruit Bat /\0/\ 16:35 01 Jan 2012

docx can only be opened by MS Office2010 or later

link was to a MS tool to allow them to be opened by older versions of office.

  Secret-Squirrel 16:39 01 Jan 2012

".....and all attempts at deleting them using deletion tools .... have failed. They cannot be moved to any other location either.....I tried booting fro the UBCD disk and deleting when not actually booted into Windows, but this also failed."

Given all those symptoms John, it sounds very much like this this is a file-system problem. If it is then you should be able to resolve it easily by doing a standard CHKDSK on the volume that contains those files. After it's completed, see if you can now delete them.

If you need step-by-step instructions then you'll need to post back your version of Windows.

  johndrew 21:04 01 Jan 2012

I have run CHKDSK which found nothing.

After much time - perhaps site loading - I managed to get into the link but it refused to download giving me the 'error' message.

I have a feeling it may all be down to the holiday season as I can't get into MS Updates either.

  Secret-Squirrel 09:24 02 Jan 2012

"I have run CHKDSK which found nothing"

That should work for files that claim to be corrupt so that's a disappointing result. Did you do the standard check or the full one that checks for bad sectors too? If it was the former then try again with the full one.

Here are some other things to try:

1) Take ownership of the files, grant yourself Full Control and then see if you can delete them. If you're running XP Home then you'll need to boot into Safe Mode to change the file permissions.

2) Ensure that the files aren't read only.

3) Boot into "Safe Mode with Command Prompt" and try to delete them from there.

4) Let us know the version of Windows you're running and the complete error messages you're receiving.

  johndrew 11:31 02 Jan 2012

I have done all the above without success and I still have a connection problem with MS Update and similar. When trying to connect I get the message "This program cannot display the webpage".

Obviously I can connect to here but not other sites.

Hang on, I just disabled my firewall (PC Tools Firewall Plus) which has never stopped access before and suddenly I can get to MS Updates. Will need to check this out.

  johndrew 12:59 02 Jan 2012

I have downloaded and installed the MS compatibility package and still no luck in deleting the two documents.

I have compared the sizes of those attached to the e-mail and those that will not delete, both of the 'corrupt' items are larger. Past experience with corrupt files has shown me that they are generally larger.

Any more suggestions??

  Fruit Bat /\0/\ 13:12 02 Jan 2012

open the emails attachments and - save as - using same name and same location as the corrupt one - see if you get the replace or change file name message - select replace and see if they will overwrite.

This thread is now locked and can not be replied to.

1x1 pixel
Elsewhere on IDG sites

Samsung Galaxy Book Flex review

The first ever AR Pride floats come to Snapchat

Spotted: New larger Apple Watch Series 6 battery

App Store : comment obtenir un remboursement ?