Removable Media Devices not Working

  John-333554 12:37 16 Apr 2005

My Mesh computer has had the same removeable media devices operating without problems for 3 years. Suddenly the floppy drive, Cd writer and DVD devices are not recognised and when I try to use them the caption "A:\ is not accessible, incorrect function" appears. the same caption applies to the Cd writer(D:\) and DVD (E:\).
In Device Manager the indication is that they are all working correctly and all drivers are OK. I have checked internal connections and also run an updated virus check. Troubleshooting programs do not find anything. Incidently, my digital camera also displays the same caption. Apart from this problem the computer is working in every other area. My operating system is XP and I have 512Mb of RAM. Any ideas?

  stalion 13:22 16 Apr 2005

have you tried system restore?

  Jak_1 13:27 16 Apr 2005

In the first instance I would try using system restore taking the pc back to a date that you know all drives worked.

Start > Control panel > System > System Restore.

Hope this works for you.

  John-333554 15:10 16 Apr 2005

I have tried system restore gradually going further back but to no avail. The suggestion that I delete the devices from Device Manager has had some success. Tentatively tried by removing the floppy drive from Device Manager and restarting. This brought back the CD Writer and DVD but although the floppy drive reinstalled it is still giving the same problem. A second attempt to delete and reinstall the floppy drive still has not cured the problem. This points to a possible fault on the floppy drive that may have triggered the other devices not to work. Still trying and welcome new suggestions.

  Technotiger 15:34 16 Apr 2005

Hi, 3years - possibly dodgy floppy drive - very cheap to buy and easy to install.


  John-333554 10:41 18 Apr 2005

Have now got drives working again, except for the floppy, by ressigning in Disk Management. This is found in the Computer Management area. I think that the floppy drive is now a serarate issue and may have been the cause of the original problem

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)