Remote NAS connection help

  bucko1986 19:03 10 Jan 2010


Please see below previous forum I opened.

Since then I have managed to set up my NAS so that I can access it remotely over the internet.

However I can only access my NAS home page i.e. the configuration settings. Does anyone know how I can actually access my files?

Thanks for any help

Sun, 10/01/[email protected]:23

Hi guys,

New to this site so please bear with me!

My problem is as follows:

I recently purchased an Iomega Home Network 500GB Hardrive. This is plugged directly into my Netgear router which is running Sky Broadbands own firmware. I have two PCs, one laptop and a PS3 all hooked up, so I can access all files internally on my home network. I use my NAS drive so that I can also access my Itunes library on any PC.

I now want to be able to access my NAS over the internet from a location outside of my home network. I am having real problems with this.

Am I right in thinking that if I can just find the external ip address for my NAS drive then I can access it using IE? If this is the case then how do I find the external IP address???

I am a bit of a newbie when it comes to networking so please if possible could you provide detailed solutions. Thanks in advance for any help


Tech Guy
Sun, 10/01/[email protected]:48

If you don't have a static IP address, you can sign you for Dynamic DNS check out: click here

Assign your NAS in the routers DMZ and you may have to alter your firewall setings, but can be done.

A word of warning about opening your NAS to the internet, it will be visible and you will get unwelcomed guests!

  mgmcc 08:33 12 Jan 2010

Presumably you're using a web browser and accessing via your *PUBLIC* IP address? Have you tried using the full path to the folder or file you're trying to access? Something like...

h t t p : //
(without the spaces)

Do that in Windows Explorer rather than in a web browser.

If that doesn't work, you may have to access files using FTP rather HTTP protocol. Again in Windows Explorer, try...

f t p : // username:password @
(without the spaces)

  bucko1986 18:43 12 Jan 2010

Thanks for the reponse. The second of your two suggestions seems to be getting me somewhere - however, it asks me for a user name and password. I have entered my correct user name and password for my nas drive(as the administrator)yet it still says 'could not log in to the FTP server with the user name and password specified' and gives me the option to re-enter.

I have also tried using the user name and password for both my router and FTP accounts set up on my NAS drive but still nothing.

Any suggestion? Thanks again - I really appreciate your help


  mgmcc 20:12 12 Jan 2010

I would have thought that it would have to be the Username/Password for the FTP accounts on the drive, unless you can access without requiring a login and by leaving the fields blank. If not, can you remove the Username/Password in the drive's settings so as to allow an anonymous connection?

Unfortunately my experience of FTP only runs to uploading and retrieving files from an ISP's webspace so, without a NAS drive to play about with, I can't use "trial & error" to try and find a solution.

  bucko1986 21:38 12 Jan 2010

mgmcc you are a hero!! It is working - finally!!! I did what you said - setting the NAS to not require a log in and that worked. Then figured out that the 'home directory' needed changing to my shared folder. Now I can log in using the fttp:// you suggested with the required user name and password.

I really can't thank you enough!!!

One last question though - how safe is this? How easy would it be for someone to access my files?

  mgmcc 22:01 12 Jan 2010

I'm a bit confused because you say you've set the NAS not to require a password, but also that you can log in with the required Username & Password.

If you do actually need to enter a Username & Password in order to access the files, then the system is secure, otherwise it isn't. Having said that, someone trying to gain access would need to be aware that there was an FTP server at your IP address, although 'bots' scanning for vulnerable servers might find it.

  bucko1986 22:02 12 Jan 2010

Sorry - my last post didn't really make sense! What I meant was that I tested it by allowing access to anyone and then realised where I had been going wrong and changed it back. Currently I do require a user name and password to access my NAS.

Thanks again

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

How to use 3D Touch on iPhone

Comment importer des contacts d’un iPhone à un autre iPhone ?