Reload woes, error message, please help

  _chris_ 17:30 03 Oct 2003

Firstly the machine (now used by my daughter) is a 266 PII running W95...yes its

The error message is as follows:
'Your multifunction device(Standard Dual PCI IDE Controller) has some child devices using 32-bit drivers and others using compatibility-mode drivers. This configuration is not supported, so your computer has been halted to prevent corruption.

After you restart your computer, Windows will use compatibility-mode drivers for each child device attached to this multifunction device. If you want to used 32-bit drivers, you may be able to obtain an updated driver for the device that caused the problem by contacting your hardware manufacturer, or you can disable the device.

Press any key to continue_'

On pressing any key the screen goes black and all I see is a flashing cursor, nothing else appears to be happening. On rebooting I select the option to start in safe mode. Normal mode just brings me back to square one. Once in safe mode navigating to System properties/device manager/hard disk controllers reveals three devices, two of which have red X's next to them:

1.Primary IDE Controller (single fifo) - red X
2.Secondary IDE Controller (single fifo) - red X
3.Standard Dual PCI IDE Controller - no conflict

Selecting the properties of either of the conflicting devices and checking the tabs:
GENERAL - Status not availablewhen in safe mode.
DRIVER - The usual no drivers are required or loaded for this device (driver update tab option)
RESOURCES - Windows cannot determine which resources this device is using. This is probably because you are in safe mode. (set configuration manually tab option)

I'm assuming that the original blue screen error message is referring to a problem with one of those devices. If I take the advice of the error message and try to remove (disable) either of the conflicting devices I get this message:

'This device is part of a multifunction device and cannot be removed separately.
To remove this device, select and remove the multifunction parent. Please note that this will also remove any other devices which are part of this multifunction device.
Parent device: No description available'

It will allow me to remove the Standard Dual PCI IDE Controller but on restarting windows it tells me to run windows set up again (which I did) but I just arrive at the original blue screen again.

How do I get back to running in normal mode? I have reloaded windows a few times on the same machine but this is the first time I've recieved an error message about any 'child devices' (what are they ??). Also from memory there have been conflicts with the same two devices mentioned before although this has never prevented the machine being used normally afterwards. The original blue screen I have never seen before as I already mentioned.

This whole episode was brought about by an 'invalid system disk error' message on start up out of the blue which appears to happen periodically for some reason (anyone know why this is ? Yes I've checked the drives, there are never any disks left in). Starting from a boot disk and reloading windows is the only way I know to get back to the desktop. I'm not an expert with computers and there is probably an easier way, anyone offer any advice on this also should (when) it happen again ?

I've tried to be as detailed as possible, look forward to any help you can give to resolve this,


  spikeychris 17:55 03 Oct 2003

Grabbed this from the groups...

Backup your reg first..

You'll want to make copies of system.dat and user.dat, which are hidden
files in the windows directory.
Go to start/run then type in regedit and ok.
The key you want to go to is:
Inside the IOS you'll see a line with the value of "noide". Delete that
line, close regedit and then reboot.

If everything was done correctly you should be up and running in full 32 bit

  _chris_ 18:33 03 Oct 2003

Dumb question I know but how do I back up my registry and make copies of system.dat and user.dat ?

Thanks for taking the time to help spikeychris

  spikeychris 18:53 03 Oct 2003

Sorry, badly typed. Backing up the reg will take care of system.dat and user.dat.

click here for the Win95 reg backup.

  _chris_ 21:54 03 Oct 2003


Thanks for the suggestion, I did as suggested but on restarting I still recieve the same error message. I fear this could become difficult to resolve. Anything further to try ?

  _chris_ 21:55 03 Oct 2003

On the bright side, I did manage to back up the system and user.dat files successfully :)

  spikeychris 11:00 04 Oct 2003

First go through all ide controllers in device manager and make sure none of
them are repeats of others.
You should have the PCI to IDE controller
Primary IDE controller
Secondary IDE controller (I've seen this show up even if it's disabled in
the BIOS and it normally won't cause any problems
May also have another standard IDE/ESDI hard disk controller (ide
controller on sound card???)
I don't know what the 4th one may be. May want to go into safe mode and
remove all ide controllers from there (will not be able to remove the
primary and secondary) reboot and let 95 redetect all the controllers.
That should get you down to the correct number of controllers for your

Now to fix the msdos compatability mode.
Go into your config.sys and autoexec.bat and rem out all ide drivers (IE cd
rom drives etc).
Next you'll need to go into the registry so it's best to go ahead and back
it up incase anything goes wrong while you're in there.
You'll want to make copies of system.dat and user.dat, which are hidden
files in the windows directory.
Go to start/run then type in regedit and ok.
The key you want to go to is:
Inside the IOS you'll see a line with the value of "noide". Delete that
line, close regedit and then reboot.

If everything was done correctly you should be up and running in full 32 bit
If you get the message about the multifunction device again you'll know you
didn't remove the line(s) out of the config.sys out autoexec.bat that were
causing a problem.

I've never seen this message come up with anything other than PCI to IDE
controllers. Mainly what happens is that real mode drivers are running for
1 of the controllers on the board. When 95 tries to load the protected mode
drivers the 2 conflict. Instead of trying to load both (which could cause
lockups/crashes/system unstability etc) 95 just unloads the protected mode
drivers assuming you want to use the real mode drivers (ie msdos
compatability mode). It does this for all the IDE controllers (IE primary
and secondary) because they are actually the same device with 2 ports.

The noide line is then put into the registry meaning that 95 should not load
the protected mode drivers anymore. Sadly the only way to get 95 to load
them again is to either go inot the registry manually and remove the line or
rename the registry and rerun setup to force it to fully rebuild.

  _chris_ 11:39 04 Oct 2003

Thats a tactful way of telling me I havent done it Ok I will attempt it again, once more thanks for your help


  _chris_ 12:31 04 Oct 2003


Following your last post I removed the Standard PCI to IDE Controller from Device Manager (Primary and Secondary wont remove as stated). TTHEN I went into regedit and removed the 'noide' line by highlighting it and selecting delete (this is right no ?).

On rebooting windows detects new hardwars and asks for drivers for the IDE/PCI controller and I let it search. It suggests drivers in a file called 'inf'. I'm not about to argue and I get the windows tour window blurb come up on the screen and I think hey, sorted at last. Just at that point I get another message which reads thus

'The LOADWC.EXE file is linked to missing export SHLWAPI.DLL:wnsprintfA'

This appears to refer to something unconnected with my problem. I click ok to clear it and all seems fine at this point. I'm now running in normal mode.

I now choose to reboot to see if we have cured everything and you can guess the rest....same blue screen error about compatibility.

It appears I'm doing everything as instructed so either I'm retarded (possible) or I'm doing it right and theres something additional thats wrong here.


  spikeychris 13:23 04 Oct 2003

The 'The LOADWC.EXE file is linked to missing export SHLWAPI.DLL:wnsprintfA' is not related its an IE problem. Did you rem out the drivers?

  spikeychris 13:33 04 Oct 2003

You need to also remove the DOS drivers from the Autoexec.bat and Config.sys for the CD-ROM drive.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

Creative studio Omnibus' brand identity for We Said Enough fights back against sexual misconduct

WWDC history: Apple's product launches since 2005

Espace de stockage : comment libérer de la mémoire sur votre iPhone ?