Reformatting a USB drive and upgrading Firmware ..

  Heefie 09:31 01 Dec 2009

Many thanks if anybody can help here …

I have a NEO KEOPS USB HDD that allows me to use it as a TV drive, i.e. it allows me to watch AVI, MPEGS etc on my TV.

I have always had problems with it in that it refuses to play ALL of some movies, it just stops in the middle and moves on to the next file, even though these files play fine on the PC or my main Hyundai player … very weird.

I have found there is a new Firmware release & have downloaded it. Unfortunately, even though this machine (and it’s better and worse, if that’s possible, brethren) is over 3 years old, the French developers STILL don’t have a working English version of their web site or a UK manual to work from !!! The following is a translation of the French instructions on how to apply the Firmware :

French to English translation
Compatible with Windows 95b / 98 / NT / 2K / Me / XP / 2003 Server / Vista

We will proceed to update your NEW KEOPS

Recover your files on your New KEOPS.

Format your New KEOPS via My Computer

Transfer the file "upgrade.rom in the root of New KEOPS

Then re-upload all your files in the New KEOPS

Create 3 separate files: VIDEO, MUSIC, PHOTO (Optional)

This is absolutely fine until I get to Step 3 … how the feck do I copy a file to “the root” of my drive ?!?!?


  howard64 09:36 01 Dec 2009

suggest they mean to your internal C; drive. ie copy it to C:

  bremner 09:48 01 Dec 2009

If the Keops drive is say 'E' then the root of it is E:\

  Heefie 09:58 01 Dec 2009

LOL, surely it's not that blatantly obviously simple that I've confused myself ?!?!?!?

I'll copy it to there & see what happens, maybe it picks it up when it powers up ?!? Weird, never seen firmware applied like this before ...

  Heefie 00:42 02 Dec 2009

OK, I unpacked it to the drive, attached it to the TV, turned it on, no apparent difference … I went into SetUp & there is an option for Firmware Upgrade … it tells me that the current version is 2007 & there is no update on the disk. I know that the version I downloaded was 2008.

I unpacked it again & this time left it in the Firmware folder, rather than unpacking it directly to the root, as insinuated, re-tried … no difference !!!

Anybody got one of these crap machines?

Anybody speak French and can ascertain from this website ... click here what the hell I am supposed to do ?!?

Damn this is frustrating !!!

  howard64 09:20 02 Dec 2009

have you tried unpacking it and putting it in the C: drive just in case it is meant to run from there?

  Heefie 10:26 02 Dec 2009

howard64, I don't understand how putting the software onto my drive C: would achieve anything, it's not an executable file ...

  howard64 16:54 02 Dec 2009

it might just be that the upgrade will look for it in the root ie drive C: of the pc rather than the external device!!

  bremner 16:55 02 Dec 2009

Whilst the instruction appears to be specific - "Transfer the file "upgrade.rom in the root of New KEOPS" it has not worked.

So you have nothing to loose in trying what howard64 says.

  Heefie 00:06 03 Dec 2009

No, I'm sorry, this just doesn't make any sense !!!

I have the KEOPS attached to my Laptop as an external USB drive ... what the hell would it know about my C: drive ?!?!?

It's a dumb drive, if I put something on my C: drive that is not an executable, what am I supposed to do, there is no processor in the USB drive to go looking elsewhere !!!

I appreciate that you are trying to help, but what you are suggesting is nonsense !!!

  woodchip 00:16 03 Dec 2009

There should be a Program to update the firmware like when you upgrade BIOS.

PS you would need to run the Update on the Computer, with the drive plugged in

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?